Radiance tutorial exercise problem

This might be a beginner question, but I couldn’t find solution anywhere. I was following the exercise on the page 14 of the radiance tutorial.

The question is to create the description of a sphere in a file named objects/things.rad. So I created something like this:

void light bright
3 100 100 100
bright sphere room
4 2 2 2 1

Then the tutorial asks to view this object with the objline command, like:

$objline /usr/local/radiance/bin/thingsa.rad | x11meta

I did that and got the following error warning:

/usr/local/radiance/bin/thingsa.rad: line 1: void: command not found
/usr/local/radiance/bin/thingsa.rad: line 2: 0: command not found
/usr/local/radiance/bin/thingsa.rad: line 3: 0: command not found
/usr/local/radiance/bin/thingsa.rad: line 4: 3: command not found
/usr/local/radiance/bin/thingsa.rad: line 5: bright: command not found
/usr/local/radiance/bin/thingsa.rad: line 6: 0: command not found
/usr/local/radiance/bin/thingsa.rad: line 7: 0: command not found
/usr/local/radiance/bin/thingsa.rad: line 8: 4: command not found
fatal - cannot open file "/usr/local/lib/meta/vchars.mta", mode "r"

Before this, the objline and x11meta cannot be found as well. But after I added all 3 folders’ paths to the .zprofile and installed Xquartz, these two are not showing warnings anymore. So I assume this has been solved.

But still I don’t understand why I got this problem. Please help me with this.
Thank you very much.

The errors don’t quite make sense – it looks like the “thingsa.rad” file is being fed directly to the shell, somehow. Do you have the C-shell installed on your system? Why is your data file in the executable directory?

Try running this from /usr/local/radiance/bin:

csh -fex objline thingsa.rad



I’m sorry, I might not being clear. I’m using MacOS system with zsh shell. I have bash and zsh installed in my laptop. I tried moving the data file to a different directory and run the code. but I got the same problem.

Thank you

You cannot use objline without the C-shell (either csh or tcsh). You should be able to use objpict to generate a picture, however. The operation is similar:

objpict scene.rad > scene.hdr


Hi Greg,

Thank you for you help. I tired the tcsh shell as you advised, but somehow I couldn’t add PATH to .cshrc file. So I tried to use ./makeall install to install it cause I don’t know what to do with it. But it’s not working:

./make: No such file or directory.
sudo: ./makeall: command not found

The installation file I used is .pkg file for macOSX. And I have command line tools.

Since I couldn’t figure out what’s the problem, I switched back to bash shell again to try objline, objpict and x11meta.

This time, objline and objpict showed messy corrupted codes. Maybe like you said, they cannot use without c-shell?

If I pipe objline with x11meta, the x11meta just flashed. And it says I can’t open the vchars.mta. Very similar to this discussion from pevlek86. Looks like an installation fault.

I want to use make to reinstall it. But it just not working. Do you know how to solve that?

The syntax for adding to a path in $HOME/.cshrc looks something like:

set path=(/usr/local/bin $path)

which is different from other shells.

As makeall will recommend, you also should set your RAYPATH environment variable, e.g:

setenv RAYPATH .:/usr/local/lib/ray

It is difficult to know exactly what is going wrong without knowing more about which version of MacOS you are using and which packages you have installed. (I.e., command-line tools, X11, etc.) What happens when you run:

which tcsh csh gcc make


Hi Greg,

I just downloaded a source code and managed to install it with ./makeall. But when I use objine, it still show this

Glad you got it to work – this is definitely progress! You need to pipe the output of objline into something that understands the binary “metafile” graphics format, such as x11meta or meta2bmp:

objline objects/things.rad | x11meta

objline objects/things.rad | meta2bmp > things.bmp
open things.bmp

Hi Greg,

Thank you for your help! I can now see the pictures. Although it shows 'cannot open /usr/local/lib/ray/meta/vchars.mta ’ again, but I created a folder named ‘meta’ and copied the file from install folders. Now it’s working. Thanks!