Problems of rvu

Hi all,
I was running rvu to preview some scene. However there occurred errors as follows:

I looked through some posts about this similar error and I still don’t know how to solve this problem.
I am using the compiled Radiance from Github on Ubuntu 20.04.

Thanks for bringing this to our attention. What happens if your run

objview -o x11 glazingvmtx.rad

Do you still see the error?


Hi Greg,
The same error occured!

And I tried objline to preview the scene and it was in effect as follows:

objline glazingvmtx1.rad | x11meta -r &

what do you get from
rvu -devices?


Hi Axel,
The same error as follows:

could you run this without the question mark, please. Sorry about my sloppy formatting.

rvu -devices


Hmm, this looks like it can’t find the QT libraries.

so you are using radiance-5.2.dd0f8e38a7-Linux.tar.gz from
is that correct?

If so, could you please run
sudo apt list --installed |grep -i qt
and share the output


First things first, uninstall that set of binaries and install one of the newer packages from LBNL’s GitHub site; the NREL packages are ancient and haven’t been supported in a long time (they weren’t supported when they were supported but that’s a convo for another time).

Head over to LBNL’s GitHub site for Radiance, where they update installers quite regularly, and have the build process for Qt-supported rvu as well-sorted as anyone:

1 Like

Hi Axel,
I am using the RADIANCE 5.4a 2021-09-28 LBNL (5.4.8aeb24b8c5) from LBNL’s GitHub site as Rob recommended.

Hi Rob,
I am using the updated Radiance from LBNL’s GitHub site but the version is not the newest. The files in the package is already compiled. So I used to unzip the tar.gz package and copy the Radiance folder to the directory /usr/local. Then the file ~/.bashrc is edited to add several environment variables as follows and then source the file. Is this installation process correct? I think several problems of commands are linked to the installation. I hope someone can provide the correct and normal installation proceducre. Thank s a lot!

export PATH=/usr/local/radiance/bin:$PATH
export RAYPATH=/usr/local/radiance/lib:$RAYPATH

The problem is either on our side, not linking to static libraries, or on your side, not having the right dynamic libraries installed. You should run the “sudo apt list” command Axel suggested and share your results. It’s our best hope of fixing the problem.


Hi Greg,
The Radiance version is the newest packages from LBNL’s GitHub site. I don’t need to compile the files, right? The result is as follows when I just didn’t install Radiance:

Here is what @Taoning_Wang wrote when I asked him about this:

I just verified qt works with latest release on my Mac. Pretty sure I don’t have qt installed, and rvu links to the qt files that come with the build binary file. I do have to click through a many security loops (those “open anyways”) from Mac.
Also verified that on ubuntu I do need to set $LD_LIBRARY_PATH to the radiance/bin directory, where all the qt shared library files are.
This person should probably try:

  1. echo $LD_LIBRARY_PATH. To see if it’s set and point to the /usr/local/radiance/bin folder.
  2. call rvu by its absolute path, so we avoid any installation/file-copy mishap.

Hi Greg,
Thanks for your attention and solutions from @Taoning_Wang. The method to set $LD_LIBRARY_PATH to the radiance/bin directory has solved this problem of rvu.
The result is as follows:


Great – I wonder why the $LD_LIBRARY_PATH was not set properly. Were there instructions you were supposed to follow, or a script that needed to be run during installation that was not? I am not familiar myself with the Linux package install process.


I guess rvu is supposed to find shared library files locally and not look for $LD_LIBRARY_PATH. Somehow that link is not working on linux but is on Mac. Need to look into the build process.

Hi Greg,
I have been using the frequently updated version of Radiance from LBNL’s Github site. The installation process is mentioned in that post:

I looked through the posts about installation in this community and found some useful suggestions. Besides, I also have installed the software Accelerad to accelerate the rendering. I followed its installation instructions( and then made similar process of Radiance. The environment variables are set in the file ~/.bashrc as follows:

However, I didn’t set the $LD_LIBRARY_PATH to the radiance/bin directory when the problem of rvu occurred!
I am not sure if the installation process is correct and I hope someone such as @Taoning_Wang1 can conclude the installation instrcutions of Radiance that is downloaded from LBNL’s Github site.