Error running rvu - libSM.6.dylib

Hi all,
I face an error when running the objview command:

objview testsurface.rad

the pop-up window shows this message:
Screenshot 2023-01-31 at 11.01.14

and the terminal:

oconv -f holedsurff.rad /var/folders/3s/4btthscs65jcq1hwcq_5k224g4jgb_/T/8gFj0UKP62/lt8719.rad > /var/folders/3s/4btthscs65jcq1hwcq_5k224g4jgb_/T/8gFj0UKP62/ov8719.oct
        rvu -vtv -vp 12 12.5 10 -vd -5 -5 -5 -vu 0 0 1 -vh 45 -vv 45 -dp 128 -ar 16 -ds 0 -dt .2 -dc .25 -dr 0 -ss 0 -st .5 -af /var/folders/3s/4btthscs65jcq1hwcq_5k224g4jgb_/T/8gFj0UKP62/af8719.amb -aa .3 -ad 256 -as 0 -av 0.36 0.36 0.36 -lr 6 -lw .003 -ps 8 -pt .16 -R /var/folders/3s/4btthscs65jcq1hwcq_5k224g4jgb_/T/8gFj0UKP62/ov8719.rif -o x11 -pe .5 /var/folders/3s/4btthscs65jcq1hwcq_5k224g4jgb_/T/8gFj0UKP62/ov8719.oct
dyld[8725]: Library not loaded: '@executable_path/libSM.6.dylib'
  Referenced from: '/Library/Radiance/bin/rvu'
  Reason: tried: '/Library/Radiance/bin/libSM.6.dylib' (code signature in <AFE0D1D9-D221-38C2-B39F-B17172171213> '/Library/Radiance/bin/libSM.6.dylib' not valid for use in process: library load disallowed by system policy), '/usr/local/lib/libSM.6.dylib' (no such file), '/usr/lib/libSM.6.dylib' (no such file)
rad: error running rvu

I tried the potential solutions for the similar issue here, which I listed below:

  • Testing objview -o x11 holedsurff.rad , which resulted in the exact same error.
  • The response to rvu -devices is the same error.
  • I have the RADIANCE 5.4a 2021-09-28 LBNL on my machine and the Radiance directories are added to PATH variable.
  • brew info qt5 gives:

==> [email protected]: stable 5.15.8 (bottled) [keg-only]
Cross-platform application and UI framework

  • I tried setting $LD_LIBRARY_PATH to the /usr/local/radiance/bin folder and did not change the error.
  • I tried calling rvu with absolute path, which did not work.

Do you have any idea on how to resolve this?

Thank you in advance,

Hi Nima,

This sounds like a Linux library compatibility issue with the github environment we’re using. I don’t know much about that, but did you try recompiling from source, using either the cmake build system or the “makeall” script at the top level?


Have you try to remove the damaged file as the pop-up suggests?
Or try to reinstall xquartz if you want to use X11.

Hi @Taoning_Wang1,

Have you try to remove the damaged file as the pop-up suggests?

When I remove, then the error changes to: “libSM.6.dylib is missing” (or something similar).

Or try to reinstall xquartz if you want to use X11

This also did not resolve the issue.

Hi @Greg_Ward ,
I haven’t tried recompiling from the source, do your mean recompiling rvu?can you please explain more about how can I do that?

You can try running this from the top ray/ directory:

./makeall install

I don’t have any experience doing this on recent versions of Linux, so I’m not 100% sure it’s going to work for you, but it’s worth a try. I don’t think there’s a direct way to recompile just rvu.


Thanks @Greg_Ward,
compiling from the source solved the problem and Xquartz window pops up after running the command. However, I only see the grey window, and the geometry defined in the .rad file is not showing.
I am testing a .rad file containing a simple polygon(test.rad):

void polygon f_7_0
12 0 0 0 4 0 0 4 5 0 0 5 0

and what I get after running objview test.rad is:

Congratulations on getting rvu compiled from source! I see you are already using objview to view this geometry, so my initial reply to this (deleted) was pointless and misleading. Sorry about that.

I guess I’d start playing with the view controls anyway, because if you got no error messages from rvu on loading your rad file, then the geometry must have loaded. I’m not sure why you weren’t presented with a view of your polygon though.

Your issue is you have created a polygon with the void object; thus, there is no material definition on it to do anything with the light.

try adding a material def, and then assign the material to your polygon e.g.:

Make this:
void plastic my_material
.5 .5 .5 0 0

And assign to your polygon like so:
my_material polygon f_7_0
12 0 0 0 4 0 0 4 5 0 0 5 0

I’m going to drink my coffee now and hope there are no more stupid errors in my responses. =)


Great, now it works.
Thanks a lot @Rob_Guglielmetti :slight_smile:

1 Like

Awesome, you’re welcome. I’m still drinking my coffee anyway…

1 Like