sudo recontrib

Dear experts,

I am trying with Three-Phase Method for Simulating Complex Fenestration,
following A McNeil tutorial.

I am using Ubuntu 14 OS. I need use sudo command because I have
GenericTranslucent20.dat material and rang.cal that they are locked anyway.
However, when I have launched sudo rcontrib, it scripts that:

sudo rcontrib -f /usr/share/radiance/klems_int.cal -b
'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2 -ad
512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells.vmx

sudo: rcontrib: command not found

Could someone say what the problem is? Thank you in advance.
Best regards,
Urtza.

···

Dear Urtza,

two comments on your installation - this should be solved before you even start using a complicated combination of commands such as the three-phase method.

First, with a correct configuration of your system you will not need to run rcontrib as super-user (sudo). Your regular user account just needs read-access to the .dat and .cal files in this case, so why would you not grant the proper permissions?

Second, as rcontrib is not found, what makes you think it is installed? Did you install Radiance from sources, did the build complete without errors, and did you include the directory containing the binaries in your PATH environment variable? Does any other Radiance command work for you?

I would recommend having a look at Axel Jacob's set of tutorials first, including the unix-introduction. Otherwise you risk messing up a lot of your models with work-arounds, and even risk the integrity of your system by using sudo where it should definitively not be applied.

Cheers, Lars.

···

Dear experts,

I am trying with Three-Phase Method for Simulating Complex Fenestration, following A McNeil tutorial.

I am using Ubuntu 14 OS. I need use sudo command because I have GenericTranslucent20.dat material and rang.cal that they are locked anyway. However, when I have launched sudo rcontrib, it scripts that:

sudo rcontrib -f /usr/share/radiance/klems_int.cal -b 'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2 -ad 512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells.vmx

sudo: rcontrib: command not found

Could someone say what the problem is? Thank you in advance.
Best regards,
Urtza.

Dear Lars,

Thank you very much for your reply.

I tried with Five-Phase method earlier and all command worked. However, now
I exported the model from Rhino and I have some materials that they need
two specific files. I do not why they do not run without sudo, placing
where there are others, as well (They keep always the padlock, I copy there
from DIVA's files. They are not from radiance package previously
installed). I use oconv, rtrace and rpict with sudo and they work without
problem. Nervertheless, if using sudo is not good I remove those materials
and I could use rcontrib without sudo.

Thank you for your suggestions. I read Axel Jacob's tutorials but rereading
will be fine.
Best regards for you,
Urtza.

"Lars O. Grobe" <[email protected]> escribió:

Dear Urtza,

two comments on your installation - this should be solved before you
even start using a complicated combination of commands such as the
three-phase method.

First, with a correct configuration of your system you will not need to
run rcontrib as super-user (sudo). Your regular user account just needs
read-access to the .dat and .cal files in this case, so why would you
not grant the proper permissions?

Second, as rcontrib is not found, what makes you think it is installed?
Did you install Radiance from sources, did the build complete without
errors, and did you include the directory containing the binaries in
your PATH environment variable? Does any other Radiance command work for
you?

I would recommend having a look at Axel Jacob's set of tutorials first,
including the unix-introduction. Otherwise you risk messing up a lot of
your models with work-arounds, and even risk the integrity of your
system by using sudo where it should definitively not be applied.

Cheers, Lars.

  Dear experts,

I am trying with Three-Phase Method for Simulating Complex Fenestration,
following A McNeil tutorial.

I am using Ubuntu 14 OS. I need use sudo command because I have
GenericTranslucent20.dat material and rang.cal that they are locked anyway.
However, when I have launched sudo rcontrib, it scripts that:

sudo rcontrib -f /usr/share/radiance/klems_int.cal -b
'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2 -ad
512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells.vmx

sudo: rcontrib: command not found

Could someone say what the problem is? Thank you in advance.
Best regards,
Urtza.

Urtza,

You should open up permissions on those two files like so:

sudo chmod 664 GenericTranslucent20.dat
sudo chmod 664 rang.cal

This changes permissions to allow owner and group read/write and everyone
read.
(you need to be in the directory or give the full path to the file).

Andy

···

On Tue, Mar 15, 2016 at 9:19 AM, <[email protected]> wrote:

Dear Lars,

Thank you very much for your reply.

I tried with Five-Phase method earlier and all command worked. However,
now I exported the model from Rhino and I have some materials that they
need two specific files. I do not why they do not run without sudo, placing
where there are others, as well (They keep always the padlock, I copy there
from DIVA's files. They are not from radiance package previously
installed). I use oconv, rtrace and rpict with sudo and they work without
problem. Nervertheless, if using sudo is not good I remove those materials
and I could use rcontrib without sudo.

Thank you for your suggestions. I read Axel Jacob's tutorials but
rereading will be fine.
Best regards for you,
Urtza.

"Lars O. Grobe" <[email protected]> escribió:

Dear Urtza,

two comments on your installation - this should be solved before you even
start using a complicated combination of commands such as the three-phase
method.

First, with a correct configuration of your system you will not need to
run rcontrib as super-user (sudo). Your regular user account just needs
read-access to the .dat and .cal files in this case, so why would you not
grant the proper permissions?

Second, as rcontrib is not found, what makes you think it is installed?
Did you install Radiance from sources, did the build complete without
errors, and did you include the directory containing the binaries in your
PATH environment variable? Does any other Radiance command work for you?

I would recommend having a look at Axel Jacob's set of tutorials first,
including the unix-introduction. Otherwise you risk messing up a lot of
your models with work-arounds, and even risk the integrity of your system
by using sudo where it should definitively not be applied.

Cheers, Lars.

Dear experts,

I am trying with Three-Phase Method for Simulating Complex Fenestration,
following A McNeil tutorial.

I am using Ubuntu 14 OS. I need use sudo command because I have
GenericTranslucent20.dat material and rang.cal that they are locked anyway.
However, when I have launched sudo rcontrib, it scripts that:

sudo rcontrib -f /usr/share/radiance/klems_int.cal -b
'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2 -ad
512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells.vmx

sudo: rcontrib: command not found

Could someone say what the problem is? Thank you in advance.
Best regards,
Urtza.

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

Urtza,
Here's some more information on file ownership and permissions for linux:
http://linuxcommand.org/lc3_lts0090.php
Andy

···

On Tue, Mar 15, 2016 at 11:23 AM, Andy McNeil <[email protected]> wrote:

Urtza,

You should open up permissions on those two files like so:

sudo chmod 664 GenericTranslucent20.dat
sudo chmod 664 rang.cal

This changes permissions to allow owner and group read/write and everyone
read.
(you need to be in the directory or give the full path to the file).

Andy

On Tue, Mar 15, 2016 at 9:19 AM, <[email protected]> wrote:

Dear Lars,

Thank you very much for your reply.

I tried with Five-Phase method earlier and all command worked. However,
now I exported the model from Rhino and I have some materials that they
need two specific files. I do not why they do not run without sudo, placing
where there are others, as well (They keep always the padlock, I copy there
from DIVA's files. They are not from radiance package previously
installed). I use oconv, rtrace and rpict with sudo and they work without
problem. Nervertheless, if using sudo is not good I remove those materials
and I could use rcontrib without sudo.

Thank you for your suggestions. I read Axel Jacob's tutorials but
rereading will be fine.
Best regards for you,
Urtza.

"Lars O. Grobe" <[email protected]> escribió:

Dear Urtza,

two comments on your installation - this should be solved before you even
start using a complicated combination of commands such as the three-phase
method.

First, with a correct configuration of your system you will not need to
run rcontrib as super-user (sudo). Your regular user account just needs
read-access to the .dat and .cal files in this case, so why would you not
grant the proper permissions?

Second, as rcontrib is not found, what makes you think it is installed?
Did you install Radiance from sources, did the build complete without
errors, and did you include the directory containing the binaries in your
PATH environment variable? Does any other Radiance command work for you?

I would recommend having a look at Axel Jacob's set of tutorials first,
including the unix-introduction. Otherwise you risk messing up a lot of
your models with work-arounds, and even risk the integrity of your system
by using sudo where it should definitively not be applied.

Cheers, Lars.

Dear experts,

I am trying with Three-Phase Method for Simulating Complex Fenestration,
following A McNeil tutorial.

I am using Ubuntu 14 OS. I need use sudo command because I have
GenericTranslucent20.dat material and rang.cal that they are locked anyway.
However, when I have launched sudo rcontrib, it scripts that:

sudo rcontrib -f /usr/share/radiance/klems_int.cal -b
'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2 -ad
512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells.vmx

sudo: rcontrib: command not found

Could someone say what the problem is? Thank you in advance.
Best regards,
Urtza.

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

Dear Andy,
Thank you very much for your instructions.
I will try with them.
Best regards,
Urtza.

Andy McNeil <[email protected]> escribió:

···

Urtza, Here's some more information on file ownership and
permissions for linux:
   http://linuxcommand.org/lc3_lts0090.php
   Andy

   On Tue, Mar 15, 2016 at 11:23 AM, Andy McNeil > <[email protected]> wrote:

Urtza,
      You should open up permissions on those two files like so:
      
       sudo chmod 664 GenericTranslucent20.dat
       sudo chmod 664 rang.cal
       
       This changes permissions to allow owner and group read/write and
everyone read.
       (you need to be in the directory or give the full path to the
file).
       
       Andy

                     On Tue, Mar 15, 2016 at 9:19 AM, >> <[email protected]> wrote:

_Dear Lars,

Thank you very much for your reply.

I tried with Five-Phase method earlier and all command worked.
However, now I exported the model from Rhino and I have some materials
that they need two specific files. I do not why they do not run
without sudo, placing where there are others, as well (They keep
always the padlock, I copy there from DIVA's files. They are not from
radiance package previously installed). I use oconv, rtrace and rpict
with sudo and they work without problem. Nervertheless, if using sudo
is not good I remove those materials and I could use rcontrib without
sudo.

Thank you for your suggestions. I read Axel Jacob's tutorials but
rereading will be fine.
Best regards for you,
Urtza.

"Lars O. Grobe" <[email protected]> escribió:_

_Dear Urtza,

two comments on your installation - this should be solved before you
even start using a complicated combination of commands such as the
three-phase method.

First, with a correct configuration of your system you will not need
to run rcontrib as super-user (sudo). Your regular user account just
needs read-access to the .dat and .cal files in this case, so why
would you not grant the proper permissions?

Second, as rcontrib is not found, what makes you think it is
installed? Did you install Radiance from sources, did the build
complete without errors, and did you include the directory containing
the binaries in your PATH environment variable? Does any other
Radiance command work for you?

I would recommend having a look at Axel Jacob's set of tutorials
first, including the unix-introduction. Otherwise you risk messing up
a lot of your models with work-arounds, and even risk the integrity
of your system by using sudo where it should definitively not be
applied.

Cheers, Lars._

_ _

             _Dear experts,

I am trying with Three-Phase Method for Simulating Complex
Fenestration, following A McNeil tutorial.

I am using Ubuntu 14 OS. I need use sudo command because I have
GenericTranslucent20.dat material and rang.cal that they are locked
anyway. However, when I have launched sudo rcontrib, it scripts that:
_

_sudo rcontrib -f /usr/share/radiance/klems_int.cal -b
'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2
-ad 512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells.vmx_

_sudo: rcontrib: command not found

Could someone say what the problem is? Thank you in advance.
Best regards,
Urtza._

________________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general_

Dear Andy,

I have tried with;

sudo chmod 664 GenericTranslucent20.dat
sudo chmod 664 rang.cal

  sudo chmod 644 GenericTranslucent20.dat
sudo chmod 644 rang.cal

   sudo chmod 600 GenericTranslucent20.dat
sudo chmod 600 rang.cal

sudo chmod 700 GenericTranslucent20.dat
sudo chmod 700 rang.cal

and the padlock continues anyway (The files there are in
/usr/local/bin/radiance/bin/ and /usr/local/bin/radiance/lib/, as well).
I have tried with rcontrib and it scripts this anyway:

   rcontrib -f /usr/share/radiance/klems_int.cal -b
'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2 -ad
512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells1.vmx

    rcontrib: fatal - cannot find data file "GenericTranslucent20.dat"

I do not know what happen but I will continue finding an error (that
padlock is very strange).
Thank you very much.
Best regards,
Urtza.
    

   

[email protected] escribió:

···

Dear Andy,
Thank you very much for your instructions.
I will try with them.
Best regards,
Urtza.

Andy McNeil <[email protected]> escribió:

Urtza, Here's some more information on file ownership and
permissions for linux:
    http://linuxcommand.org/lc3_lts0090.php
    Andy

    On Tue, Mar 15, 2016 at 11:23 AM, Andy McNeil >> <[email protected]> wrote:

Urtza,
       You should open up permissions on those two files like so:
          
        sudo chmod 664 GenericTranslucent20.dat
        sudo chmod 664 rang.cal
        
        This changes permissions to allow owner and group read/write
and everyone read.
        (you need to be in the directory or give the full path to the
file).
        
        Andy

                        On Tue, Mar 15, 2016 at 9:19 AM, >>> <[email protected]> wrote:

_Dear Lars,

Thank you very much for your reply.

I tried with Five-Phase method earlier and all command worked.
However, now I exported the model from Rhino and I have some
materials that they need two specific files. I do not why they do not
run without sudo, placing where there are others, as well (They keep
always the padlock, I copy there from DIVA's files. They are not from
radiance package previously installed). I use oconv, rtrace and rpict
with sudo and they work without problem. Nervertheless, if using sudo
is not good I remove those materials and I could use rcontrib without
sudo.

Thank you for your suggestions. I read Axel Jacob's tutorials but
rereading will be fine.
Best regards for you,
Urtza.

"Lars O. Grobe" <[email protected]> escribió:_

_Dear Urtza,

two comments on your installation - this should be solved before you
even start using a complicated combination of commands such as the
three-phase method.

First, with a correct configuration of your system you will not need
to run rcontrib as super-user (sudo). Your regular user account just
needs read-access to the .dat and .cal files in this case, so why
would you not grant the proper permissions?

Second, as rcontrib is not found, what makes you think it is
installed? Did you install Radiance from sources, did the build
complete without errors, and did you include the directory
containing the binaries in your PATH environment variable? Does any
other Radiance command work for you?

I would recommend having a look at Axel Jacob's set of tutorials
first, including the unix-introduction. Otherwise you risk messing
up a lot of your models with work-arounds, and even risk the
integrity of your system by using sudo where it should definitively
not be applied.

Cheers, Lars._

_ _

              _Dear experts,

I am trying with Three-Phase Method for Simulating Complex
Fenestration, following A McNeil tutorial.

I am using Ubuntu 14 OS. I need use sudo command because I have
GenericTranslucent20.dat material and rang.cal that they are locked
anyway. However, when I have launched sudo rcontrib, it scripts that:
_

_sudo rcontrib -f /usr/share/radiance/klems_int.cal -b
'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2
-ad 512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells.vmx_

_sudo: rcontrib: command not found

Could someone say what the problem is? Thank you in advance.
Best regards,
Urtza._

________________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general_

A "file not found" error is different from the permissions error you were getting. Do you have your lib directory set in your RAYPATH environment variable? I came in this one late so forgive me if this is redundant but you should have a RAYPATH defined, and it should point to your lib dir (where you should have all the Radiance lib files, such as these dat files and other critical files for Radiance's operation). Most of us also add the current working directory (".") to the PATH and RAYPATH as well. (Your PATH should point to wherever you have the Radiance binaries.)

You should not have multiple copies of everything as it makes it hard to maintain consistency, and makes troubleshooting these kinds of path and permissions errors harder too.

···

On 3/16/16, 5:23 AM, "[email protected]<mailto:[email protected]>" <[email protected]<mailto:[email protected]>> wrote:

Dear Andy,

I have tried with;

sudo chmod 664 GenericTranslucent20.dat
sudo chmod 664 rang.cal

sudo chmod 644 GenericTranslucent20.dat
sudo chmod 644 rang.cal

sudo chmod 600 GenericTranslucent20.dat
sudo chmod 600 rang.cal

sudo chmod 700 GenericTranslucent20.dat
sudo chmod 700 rang.cal

and the padlock continues anyway (The files there are in /usr/local/bin/radiance/bin/ and /usr/local/bin/radiance/lib/, as well). I have tried with rcontrib and it scripts this anyway:

rcontrib -f /usr/share/radiance/klems_int.cal -b 'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2 -ad 512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells1.vmx

rcontrib: fatal - cannot find data file "GenericTranslucent20.dat"

I do not know what happen but I will continue finding an error (that padlock is very strange).
Thank you very much.
Best regards,
Urtza.

[email protected]<mailto:[email protected]> escribió:

Dear Andy,
Thank you very much for your instructions.
I will try with them.
Best regards,
Urtza.

Andy McNeil <[email protected]<mailto:[email protected]>> escribió:

Urtza,
Here's some more information on file ownership and permissions for linux:
http://linuxcommand.org/lc3_lts0090.php
Andy

On Tue, Mar 15, 2016 at 11:23 AM, Andy McNeil <[email protected]<mailto:[email protected]>> wrote:
Urtza,

You should open up permissions on those two files like so:

sudo chmod 664 GenericTranslucent20.dat
sudo chmod 664 rang.cal

This changes permissions to allow owner and group read/write and everyone read.
(you need to be in the directory or give the full path to the file).

Andy

On Tue, Mar 15, 2016 at 9:19 AM, <[email protected]<mailto:[email protected]>> wrote:

Dear Lars,

Thank you very much for your reply.

I tried with Five-Phase method earlier and all command worked. However, now I exported the model from Rhino and I have some materials that they need two specific files. I do not why they do not run without sudo, placing where there are others, as well (They keep always the padlock, I copy there from DIVA's files. They are not from radiance package previously installed). I use oconv, rtrace and rpict with sudo and they work without problem. Nervertheless, if using sudo is not good I remove those materials and I could use rcontrib without sudo.

Thank you for your suggestions. I read Axel Jacob's tutorials but rereading will be fine.
Best regards for you,
Urtza.

"Lars O. Grobe" <[email protected]<mailto:[email protected]>> escribió:

Dear Urtza,

two comments on your installation - this should be solved before you even start using a complicated combination of commands such as the three-phase method.

First, with a correct configuration of your system you will not need to run rcontrib as super-user (sudo). Your regular user account just needs read-access to the .dat and .cal files in this case, so why would you not grant the proper permissions?

Second, as rcontrib is not found, what makes you think it is installed? Did you install Radiance from sources, did the build complete without errors, and did you include the directory containing the binaries in your PATH environment variable? Does any other Radiance command work for you?

I would recommend having a look at Axel Jacob's set of tutorials first, including the unix-introduction. Otherwise you risk messing up a lot of your models with work-arounds, and even risk the integrity of your system by using sudo where it should definitively not be applied.

Cheers, Lars.

Dear experts,

I am trying with Three-Phase Method for Simulating Complex Fenestration, following A McNeil tutorial.

I am using Ubuntu 14 OS. I need use sudo command because I have GenericTranslucent20.dat material and rang.cal that they are locked anyway. However, when I have launched sudo rcontrib, it scripts that:

sudo rcontrib -f /usr/share/radiance/klems_int.cal -b 'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2 -ad 512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells.vmx

sudo: rcontrib: command not found

Could someone say what the problem is? Thank you in advance.
Best regards,
Urtza.

_______________________________________________
Radiance-general mailing list
[email protected]<mailto:[email protected]>
http://www.radiance-online.org/mailman/listinfo/radiance-general

It could be that the directory is not in your RAYPATH, but it is in the RAYPATH for root.

Try:
echo $RAYPATH
sudo echo $RAYPATH

Are there any differences in the output?

Also, it could be that your user doesn't have read permission in the directory containing the files. Try using ls -l on every directory in the path to find out (both lower case L).

As a last resort, I'd copy the files to the working directory, change the owner, permissions, and add "." to RAYPATH. I agree with Lars that I'd never use sudo to run user level commands.

Andy

···

On Mar 16, 2016, at 4:23 AM, [email protected] wrote:

Dear Andy,

I have tried with;

sudo chmod 664 GenericTranslucent20.dat
sudo chmod 664 rang.cal

sudo chmod 644 GenericTranslucent20.dat
sudo chmod 644 rang.cal

sudo chmod 600 GenericTranslucent20.dat
sudo chmod 600 rang.cal

sudo chmod 700 GenericTranslucent20.dat
sudo chmod 700 rang.cal

and the padlock continues anyway (The files there are in /usr/local/bin/radiance/bin/ and /usr/local/bin/radiance/lib/, as well). I have tried with rcontrib and it scripts this anyway:

rcontrib -f /usr/share/radiance/klems_int.cal -b 'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2 -ad 512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells1.vmx

rcontrib: fatal - cannot find data file "GenericTranslucent20.dat"

I do not know what happen but I will continue finding an error (that padlock is very strange).
Thank you very much.
Best regards,
Urtza.

[email protected] escribió:

Dear Andy,
Thank you very much for your instructions.
I will try with them.
Best regards,
Urtza.

Andy McNeil <[email protected]> escribió:

Urtza,
Here's some more information on file ownership and permissions for linux:
http://linuxcommand.org/lc3_lts0090.php
Andy

On Tue, Mar 15, 2016 at 11:23 AM, Andy McNeil <[email protected]> wrote:
Urtza,

You should open up permissions on those two files like so:

sudo chmod 664 GenericTranslucent20.dat
sudo chmod 664 rang.cal

This changes permissions to allow owner and group read/write and everyone read.
(you need to be in the directory or give the full path to the file).

Andy

On Tue, Mar 15, 2016 at 9:19 AM, <[email protected]> wrote:
Dear Lars,

Thank you very much for your reply.

I tried with Five-Phase method earlier and all command worked. However, now I exported the model from Rhino and I have some materials that they need two specific files. I do not why they do not run without sudo, placing where there are others, as well (They keep always the padlock, I copy there from DIVA's files. They are not from radiance package previously installed). I use oconv, rtrace and rpict with sudo and they work without problem. Nervertheless, if using sudo is not good I remove those materials and I could use rcontrib without sudo.

Thank you for your suggestions. I read Axel Jacob's tutorials but rereading will be fine.
Best regards for you,
Urtza.

"Lars O. Grobe" <[email protected]> escribió:

Dear Urtza,

two comments on your installation - this should be solved before you even start using a complicated combination of commands such as the three-phase method.

First, with a correct configuration of your system you will not need to run rcontrib as super-user (sudo). Your regular user account just needs read-access to the .dat and .cal files in this case, so why would you not grant the proper permissions?

Second, as rcontrib is not found, what makes you think it is installed? Did you install Radiance from sources, did the build complete without errors, and did you include the directory containing the binaries in your PATH environment variable? Does any other Radiance command work for you?

I would recommend having a look at Axel Jacob's set of tutorials first, including the unix-introduction. Otherwise you risk messing up a lot of your models with work-arounds, and even risk the integrity of your system by using sudo where it should definitively not be applied.

Cheers, Lars.

Dear experts,

I am trying with Three-Phase Method for Simulating Complex Fenestration, following A McNeil tutorial.

I am using Ubuntu 14 OS. I need use sudo command because I have GenericTranslucent20.dat material and rang.cal that they are locked anyway. However, when I have launched sudo rcontrib, it scripts that:

sudo rcontrib -f /usr/share/radiance/klems_int.cal -b 'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2 -ad 512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells.vmx

sudo: rcontrib: command not found

Could someone say what the problem is? Thank you in advance.
Best regards,
Urtza.

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

Dear Andy and Robert,

Thanks for your suggestions.
Therefore, on one hand, I have tried with;

1) echo $RAYPATH
. : /usr/local/bin/radiance/lib

2) sudo echo $RAYPATH
. : /usr/local/bin/radiance/lib

(The outputs are the same)

3) urtza@urtza-VirtualBox:/usr/local/bin/radiance/lib$ ls
There appear all Radiance data files and GenericTranslucent20.dat and
rang.cal as well

(The programs are in urtza@urtza-VirtualBox:/usr/local/bin/radiance/bin$ ,
and I think that I have to remove from "bin" directory
GenericTranslucent20.dat and rang.cal, which appears there as well)

I do not know if I have problems with the installation, but I will not use
sudo for user level commands.

On the other hand, (I have changed that material for other one and I have
launched dctimestep). The .xml file, which they have lent for my PhD, is
obtained by goniophotometer.

1) Ubuntu 14:
  dctimestep -n 8760 photocells.vmx Film3M_145x1297_9142012_t.xml
southeast.dmx Barcelona.smx > illum.dat
  
  Usage: dctimestep DCspec [tregvec]
   or: dctimestep Vspec Tbsdf.xml Dmat.dat [tregvec]

2) Windows 8:

dctimestep photocells.vmx Film3M_145x1297_9142012_t.xml southeast.dmx
Barcelona.smx > illum.dat

fatal - unexpected column count in header

I checked with others files that I got and this files seem similar.

Thank you very much in advance.
Best regards for you,
Urtza.

Andy McNeil <[email protected]> escribió:

It could be that the directory is not in your RAYPATH, but it is in the
RAYPATH for root.
   
   Try:
   echo $RAYPATH
   sudo echo $RAYPATH
   
   Are there any differences in the output?
   
   Also, it could be that your user doesn't have read permission in the
directory containing the files. Try using ls -l on every directory in
the path to find out (both lower case L).
   
   As a last resort, I'd copy the files to the working directory, change
the owner, permissions, and add "." to RAYPATH. I agree with Lars that
I'd never use sudo to run user level commands.
   
   Andy
   

  Dear Andy,

I have tried with;

sudo chmod 664 GenericTranslucent20.dat
sudo chmod 664 rang.cal

  sudo chmod 644 GenericTranslucent20.dat
sudo chmod 644 rang.cal

   sudo chmod 600 GenericTranslucent20.dat
sudo chmod 600 rang.cal

sudo chmod 700 GenericTranslucent20.dat
sudo chmod 700 rang.cal

and the padlock continues anyway (The files there are in
/usr/local/bin/radiance/bin/ and /usr/local/bin/radiance/lib/, as well).
I have tried with rcontrib and it scripts this anyway:

   rcontrib -f /usr/share/radiance/klems_int.cal -b
'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2 -ad
512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells1.vmx

    rcontrib: fatal - cannot find data file "GenericTranslucent20.dat"

I do not know what happen but I will continue finding an error (that
padlock is very strange).
Thank you very much.
Best regards,
Urtza.
    

   

[email protected] escribió:

···

On Mar 16, 2016, at 4:23 AM, [email protected] wrote:

Dear Andy,
Thank you very much for your instructions.
I will try with them.
Best regards,
Urtza.

Andy McNeil <[email protected]> escribió:

Urtza, Here's some more information on file ownership and
permissions for linux:
    http://linuxcommand.org/lc3_lts0090.php
    Andy

    On Tue, Mar 15, 2016 at 11:23 AM, Andy McNeil >> <[email protected]> wrote:

Urtza,
       You should open up permissions on those two files like so:
          
        sudo chmod 664 GenericTranslucent20.dat
        sudo chmod 664 rang.cal
        
        This changes permissions to allow owner and group read/write
and everyone read.
        (you need to be in the directory or give the full path to the
file).
        
        Andy

                        On Tue, Mar 15, 2016 at 9:19 AM, >>> <[email protected]> wrote:

_Dear Lars,

Thank you very much for your reply.

I tried with Five-Phase method earlier and all command worked.
However, now I exported the model from Rhino and I have some
materials that they need two specific files. I do not why they do not
run without sudo, placing where there are others, as well (They keep
always the padlock, I copy there from DIVA's files. They are not from
radiance package previously installed). I use oconv, rtrace and rpict
with sudo and they work without problem. Nervertheless, if using sudo
is not good I remove those materials and I could use rcontrib without
sudo.

Thank you for your suggestions. I read Axel Jacob's tutorials but
rereading will be fine.
Best regards for you,
Urtza.

"Lars O. Grobe" <[email protected]> escribió:_

_Dear Urtza,

two comments on your installation - this should be solved before you
even start using a complicated combination of commands such as the
three-phase method.

First, with a correct configuration of your system you will not need
to run rcontrib as super-user (sudo). Your regular user account just
needs read-access to the .dat and .cal files in this case, so why
would you not grant the proper permissions?

Second, as rcontrib is not found, what makes you think it is
installed? Did you install Radiance from sources, did the build
complete without errors, and did you include the directory
containing the binaries in your PATH environment variable? Does any
other Radiance command work for you?

I would recommend having a look at Axel Jacob's set of tutorials
first, including the unix-introduction. Otherwise you risk messing
up a lot of your models with work-arounds, and even risk the
integrity of your system by using sudo where it should definitively
not be applied.

Cheers, Lars._

_ _

              _Dear experts,

I am trying with Three-Phase Method for Simulating Complex
Fenestration, following A McNeil tutorial.

I am using Ubuntu 14 OS. I need use sudo command because I have
GenericTranslucent20.dat material and rang.cal that they are locked
anyway. However, when I have launched sudo rcontrib, it scripts that:
_

_sudo rcontrib -f /usr/share/radiance/klems_int.cal -b
'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2
-ad 512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells.vmx_

_sudo: rcontrib: command not found

Could someone say what the problem is? Thank you in advance.
Best regards,
Urtza._

________________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general_

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

Hi Urtza,
I'm having trouble following what errors we're debugging. Are you okay not
using those materials, because with minimal effort you should be able to
fix it. If you look at the links Lars and I sent you can learn about
permissions and fix the padlock situation.
my comments are inline below.
Best,
Andy

Dear Andy and Robert,

Thanks for your suggestions.
Therefore, on one hand, I have tried with;

1) echo $RAYPATH
. : /usr/local/bin/radiance/lib

2) sudo echo $RAYPATH
. : /usr/local/bin/radiance/lib

(The outputs are the same)

Then I wonder why the files are found when you run with sudo but not found
without sudo. Or am I mis-understanding what is going on.

3) urtza@urtza-VirtualBox:/usr/local/bin/radiance/lib$ ls
There appear all Radiance data files and GenericTranslucent20.dat and
rang.cal as well

(The programs are in urtza@urtza-VirtualBox:/usr/local/bin/radiance/bin$
, and I think that I have to remove from "bin" directory
GenericTranslucent20.dat and rang.cal, which appears there as well)

this doesn't help, you need to use the -l (lowercase L) option with ls, as
I orginally suggested, to report the file and directory permissions. And it
would help if you did it for every directory in the path. like this:

ls -l /usr/local/bin/radiance/bin
ls -l /usr/local/bin/radiance
ls -l /usr/local/bin/
ls -l /usr/local/bin/radiance/lib

I do not know if I have problems with the installation, but I will not use
sudo for user level commands.

On the other hand, (I have changed that material for other one and I have
launched dctimestep). The .xml file, which they have lent for my PhD, is
obtained by goniophotometer.

1) Ubuntu 14:
dctimestep -n 8760 photocells.vmx Film3M_145x1297_9142012_t.xml
southeast.dmx Barcelona.smx > illum.dat

Usage: dctimestep DCspec [tregvec]
   or: dctimestep Vspec Tbsdf.xml Dmat.dat [tregvec]

2) Windows 8:

dctimestep photocells.vmx Film3M_145x1297_9142012_t.xml southeast.dmx
Barcelona.smx > illum.dat

fatal - unexpected column count in header

I checked with others files that I got and this files seem similar.

The tutorial is outdated. dctiemstep no longer accepts the -n 8760 option.
This info is now contained in the matrix headers. run it again without -n.

···

On Thu, Mar 17, 2016 at 2:23 AM, <[email protected]> wrote:

Thank you very much in advance.
Best regards for you,
Urtza.

Andy McNeil <[email protected]> escribió:

It could be that the directory is not in your RAYPATH, but it is in the
RAYPATH for root.

Try:
echo $RAYPATH
sudo echo $RAYPATH

Are there any differences in the output?

Also, it could be that your user doesn't have read permission in the
directory containing the files. Try using ls -l on every directory in the
path to find out (both lower case L).

As a last resort, I'd copy the files to the working directory, change the
owner, permissions, and add "." to RAYPATH. I agree with Lars that I'd
never use sudo to run user level commands.

Andy

On Mar 16, 2016, at 4:23 AM, [email protected] wrote:

Dear Andy,

I have tried with;

sudo chmod 664 GenericTranslucent20.dat
sudo chmod 664 rang.cal

sudo chmod 644 GenericTranslucent20.dat
sudo chmod 644 rang.cal

sudo chmod 600 GenericTranslucent20.dat
sudo chmod 600 rang.cal

sudo chmod 700 GenericTranslucent20.dat
sudo chmod 700 rang.cal

and the padlock continues anyway (The files there are in
/usr/local/bin/radiance/bin/ and /usr/local/bin/radiance/lib/, as well). I
have tried with rcontrib and it scripts this anyway:

rcontrib -f /usr/share/radiance/klems_int.cal -b
'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2 -ad
512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells1.vmx

rcontrib: fatal - cannot find data file "GenericTranslucent20.dat"

I do not know what happen but I will continue finding an error (that
padlock is very strange).
Thank you very much.
Best regards,
Urtza.

[email protected] escribió:

Dear Andy,
Thank you very much for your instructions.
I will try with them.
Best regards,
Urtza.

Andy McNeil <[email protected]> escribió:

Urtza,
Here's some more information on file ownership and permissions for linux:
http://linuxcommand.org/lc3_lts0090.php
Andy

On Tue, Mar 15, 2016 at 11:23 AM, Andy McNeil <[email protected]> > wrote:

Urtza,

You should open up permissions on those two files like so:

sudo chmod 664 GenericTranslucent20.dat
sudo chmod 664 rang.cal

This changes permissions to allow owner and group read/write and everyone
read.
(you need to be in the directory or give the full path to the file).

Andy

On Tue, Mar 15, 2016 at 9:19 AM, <[email protected]> wrote:

*Dear Lars, Thank you very much for your reply. I tried with Five-Phase
method earlier and all command worked. However, now I exported the model
from Rhino and I have some materials that they need two specific files. I
do not why they do not run without sudo, placing where there are others, as
well (They keep always the padlock, I copy there from DIVA's files. They
are not from radiance package previously installed). I use oconv, rtrace
and rpict with sudo and they work without problem. Nervertheless, if using
sudo is not good I remove those materials and I could use rcontrib without
sudo. Thank you for your suggestions. I read Axel Jacob's tutorials but
rereading will be fine. Best regards for you, Urtza. "Lars O. Grobe"
<[email protected] <[email protected]>> escribió:*

*Dear Urtza, two comments on your installation - this should be solved
before you even start using a complicated combination of commands such as
the three-phase method. First, with a correct configuration of your system
you will not need to run rcontrib as super-user (sudo). Your regular user
account just needs read-access to the .dat and .cal files in this case, so
why would you not grant the proper permissions? Second, as rcontrib is not
found, what makes you think it is installed? Did you install Radiance from
sources, did the build complete without errors, and did you include the
directory containing the binaries in your PATH environment variable? Does
any other Radiance command work for you? I would recommend having a look at
Axel Jacob's set of tutorials first, including the unix-introduction.
Otherwise you risk messing up a lot of your models with work-arounds, and
even risk the integrity of your system by using sudo where it should
definitively not be applied. Cheers, Lars.*

*Dear experts, I am trying with Three-Phase Method for Simulating
Complex Fenestration, following A McNeil tutorial. I am using Ubuntu 14 OS.
I need use sudo command because I have GenericTranslucent20.dat material
and rang.cal that they are locked anyway. However, when I have launched
sudo rcontrib, it scripts that: *

*sudo rcontrib -f /usr/share/radiance/klems_int.cal -b
'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2 -ad
512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells.vmx*

*sudo: rcontrib: command not found Could someone say what the problem
is? Thank you in advance. Best regards, Urtza.*

*_______________________________________________ Radiance-general
mailing list [email protected]
<[email protected]>
http://www.radiance-online.org/mailman/listinfo/radiance-general
<http://www.radiance-online.org/mailman/listinfo/radiance-general>*

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

Dear Andy,

Thank you very much. Lars's and yours permission suggestions have helped
me.
I checked the directories by ls -l :
Every files have "-rwxrwxrwx 1 root root" permission description except
GenericTranslucent20.dat and rang.cal files; "-rwx------ 1 root root.
I changed the permission by "sudo chmod 777 file" and now the two files
have the same permission as others.
(plugins and /usr/local/bin/radiance and /usr/local/bin/radiance have
"drwxrwxrwx 3 root root" description)

I have launched and now it works. Thanks.
(Note that, I put this two files in my folder with padlock and then I run
with sudo and it works but with rcontrib no. Now, it seems that I put
everything ok and I do not need to do that, which could be not good)

Regarding dctimestep, I remove -n 8760 parameter but it seems that I have
problems with Sky Matrix. The steps have been these:

epw2wea ESP_Barcelona.081810_IWEC.epw Barcelona.wea
  place BARCELONA_ESP
  latitude 41.28
  longitude -2.07
  time_zone -15.00
  site_elevation 6.0
  weather_data_file_units 1
  
  gendaymtx -m 4 Barcelona.wea > Barcelona.smx
  
  dctimestep photocells.vmx Film3M_145x1297_9142012_t.xml southest.dmx
Barcelona.smx > illum.dat
  fatal - unexpected EOF reading Barcelona.smx

I would be very grateful if you could find the problem. Thank you very much
in advance.
Best regards,
Urtza.

  

Andy McNeil <[email protected]> escribió:

···

Hi Urtza, I'm having trouble following what errors we're debugging.
Are you okay not using those materials, because with minimal effort you
should be able to fix it. If you look at the links Lars and I sent you
can learn about permissions and fix the padlock situation.
    my comments are inline below.
    Best,
    Andy

     On Thu, Mar 17, 2016 at 2:23 AM, <[email protected]> wrote:

_Dear Andy and Robert,

Thanks for your suggestions.
Therefore, on one hand, I have tried with;

1) echo $RAYPATH
. : /usr/local/bin/radiance/lib

2) sudo echo $RAYPATH
. : /usr/local/bin/radiance/lib

(The outputs are the same)_

      _Then I wonder why the files are found when you run with sudo but
not found without sudo. Or am I mis-understanding what is going on._

_3) urtza@urtza-VirtualBox:/usr/local/bin/radiance/lib$ ls
There appear all Radiance data files and GenericTranslucent20.dat and
rang.cal as well

(The programs are in
urtza@urtza-VirtualBox:/usr/local/bin/radiance/bin$ , and I think that
I have to remove from "bin" directory GenericTranslucent20.dat and
rang.cal, which appears there as well)_

      
      _this doesn't help, you need to use the -l (lowercase L) option
with ls, as I orginally suggested, to report the file and directory
permissions. And it would help if you did it for every directory in the
path. like this:_
      _ _
      _ls -l /usr/local/bin/radiance/bin_
      _ls -l /usr/local/bin/radiance_
      _ls -l /usr/local/bin/_
      _ls -l /usr/local/bin/radiance/lib_
      

_I do not know if I have problems with the installation, but I will not
use sudo for user level commands.

On the other hand, (I have changed that material for other one and I
have launched dctimestep). The .xml file, which they have lent for my
PhD, is obtained by goniophotometer.

1) Ubuntu 14:_
        _dctimestep -n 8760 photocells.vmx
Film3M_145x1297_9142012_t.xml southeast.dmx Barcelona.smx > illum.dat_
        _ _
        _Usage: dctimestep DCspec [tregvec]_
        _ or: dctimestep Vspec Tbsdf.xml Dmat.dat [tregvec]_

_2) Windows 8:

dctimestep photocells.vmx Film3M_145x1297_9142012_t.xml southeast.dmx
Barcelona.smx > illum.dat

fatal - unexpected column count in header

I checked with others files that I got and this files seem similar. _

      
      _The tutorial is outdated. dctiemstep no longer accepts the -n
8760 option. This info is now contained in the matrix headers. run it
again without -n._
      
      _ _

_Thank you very much in advance.
Best regards for you,
Urtza.
_

_Andy McNeil <[email protected]> escribió:_

_It could be that the directory is not in your RAYPATH, but it is in
the RAYPATH for root. _
            _ _
            _Try:_
            _echo $RAYPATH_
            _sudo echo $RAYPATH_
            _ _
            _Are there any differences in the output?_
            _ _
            _Also, it could be that your user doesn't have read
permission in the directory containing the files. Try using ls -l on
every directory in the path to find out (both lower case L). _
            _ _
            _As a last resort, I'd copy the files to the working
directory, change the owner, permissions, and add "." to RAYPATH. I
agree with Lars that I'd never use sudo to run user level commands. _
            _ _
            _Andy_
            _ _

_On Mar 16, 2016, at 4:23 AM, [email protected] wrote:
_

_ _

          _Dear Andy,

I have tried with;

sudo chmod 664 GenericTranslucent20.dat
sudo chmod 664 rang.cal_

          _sudo chmod 644 GenericTranslucent20.dat
sudo chmod 644 rang.cal_

           _sudo chmod 600 GenericTranslucent20.dat
sudo chmod 600 rang.cal

sudo chmod 700 GenericTranslucent20.dat
sudo chmod 700 rang.cal

and the padlock continues anyway (The files there are in
/usr/local/bin/radiance/bin/ and /usr/local/bin/radiance/lib/, as
well). I have tried with rcontrib and it scripts this anyway:
_
           _rcontrib -f /usr/share/radiance/klems_int.cal -b
'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2
-ad 512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells1.vmx_

            _rcontrib: fatal - cannot find data file
"GenericTranslucent20.dat"

I do not know what happen but I will continue finding an error (that
padlock is very strange).
Thank you very much.
Best regards,
Urtza._
            _ _

           _ _

[email protected] escribió:_

_Dear Andy,
Thank you very much for your instructions.
I will try with them.
Best regards,
Urtza.

Andy McNeil <[email protected]> escribió:_

_Urtza, _ _Here's some more information on
file ownership and permissions for linux:_
             _http://linuxcommand.org/lc3_lts0090.php_
             _Andy_

             _On Tue, Mar 15, 2016 at 11:23 AM, Andy McNeil
<[email protected]> wrote:_

_Urtza, _ _ _
                _You should open up permissions on those two files
like so: _ _ _
                 _sudo chmod 664 GenericTranslucent20.dat_
                 _sudo chmod 664 rang.cal_
                 _ _
                 _This changes permissions to allow owner and group
read/write and everyone read._
                 _(you need to be in the directory or give the full
path to the file)._
                 _ _
                 _Andy_

                                                   _On Tue, Mar 15,
2016 at 9:19 AM, <[email protected]> wrote:_

__Dear Lars,

Thank you very much for your reply.

I tried with Five-Phase method earlier and all command worked.
However, now I exported the model from Rhino and I have some
materials that they need two specific files. I do not why they do
not run without sudo, placing where there are others, as well (They
keep always the padlock, I copy there from DIVA's files. They are
not from radiance package previously installed). I use oconv,
rtrace and rpict with sudo and they work without problem.
Nervertheless, if using sudo is not good I remove those materials
and I could use rcontrib without sudo.

Thank you for your suggestions. I read Axel Jacob's tutorials but
rereading will be fine.
Best regards for you,
Urtza.

"Lars O. Grobe" <[email protected]> escribió:__

__Dear Urtza,

two comments on your installation - this should be solved before
you even start using a complicated combination of commands such as
the three-phase method.

First, with a correct configuration of your system you will not
need to run rcontrib as super-user (sudo). Your regular user
account just needs read-access to the .dat and .cal files in this
case, so why would you not grant the proper permissions?

Second, as rcontrib is not found, what makes you think it is
installed? Did you install Radiance from sources, did the build
complete without errors, and did you include the directory
containing the binaries in your PATH environment variable? Does
any other Radiance command work for you?

I would recommend having a look at Axel Jacob's set of tutorials
first, including the unix-introduction. Otherwise you risk messing
up a lot of your models with work-arounds, and even risk the
integrity of your system by using sudo where it should
definitively not be applied.

Cheers, Lars._
_

__ __

                       __Dear experts,

I am trying with Three-Phase Method for Simulating Complex
Fenestration, following A McNeil tutorial.

I am using Ubuntu 14 OS. I need use sudo command because I have
GenericTranslucent20.dat material and rang.cal that they are locked
anyway. However, when I have launched sudo rcontrib, it scripts
that:
__

__sudo rcontrib -f /usr/share/radiance/klems_int.cal -b
'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab
2 -ad 512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells.vmx__

__sudo: rcontrib: command not found

Could someone say what the problem is? Thank you in advance.
Best regards,
Urtza.__

_ _

_________________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general_
_

_ _

_ _

________________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general_

________________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general_

Hi Urtza,

glad your materials are finally working.
The most common cause of the error you are receiving is not having the
number of rows in your view matrix. You can use getinfo to look at the
header of your view matrix like this:
getinfo photocells.vmx

is there a line starting with NROWS=

If not, then you can use a text editor to add NROWS=10 (replace 10 with
your number of sensor points). This can be added in the rcontrib command by
adding -y 10

This is one of the many changes in radiance that makes the three phase
tutorial outdated. Sorry.

Andy

···

On Fri, Mar 18, 2016 at 4:56 AM, <[email protected]> wrote:

Dear Andy,

Thank you very much. Lars's and yours permission suggestions have helped
me.
I checked the directories by ls -l :
Every files have "-rwxrwxrwx 1 root root" permission description except
GenericTranslucent20.dat and rang.cal files; "-rwx------ 1 root root.
I changed the permission by "sudo chmod 777 file" and now the two files
have the same permission as others.
(plugins and /usr/local/bin/radiance and /usr/local/bin/radiance have
"drwxrwxrwx 3 root root" description)

I have launched and now it works. Thanks.
(Note that, I put this two files in my folder with padlock and then I run
with sudo and it works but with rcontrib no. Now, it seems that I put
everything ok and I do not need to do that, which could be not good)

Regarding dctimestep, I remove -n 8760 parameter but it seems that I have
problems with Sky Matrix. The steps have been these:

epw2wea ESP_Barcelona.081810_IWEC.epw Barcelona.wea
place BARCELONA_ESP
latitude 41.28
longitude -2.07
time_zone -15.00
site_elevation 6.0
weather_data_file_units 1

gendaymtx -m 4 Barcelona.wea > Barcelona.smx

dctimestep photocells.vmx Film3M_145x1297_9142012_t.xml southest.dmx
Barcelona.smx > illum.dat
fatal - unexpected EOF reading Barcelona.smx

I would be very grateful if you could find the problem. Thank you very
much in advance.
Best regards,
Urtza.

Andy McNeil <[email protected]> escribió:

Hi Urtza,
I'm having trouble following what errors we're debugging. Are you okay not
using those materials, because with minimal effort you should be able to
fix it. If you look at the links Lars and I sent you can learn about
permissions and fix the padlock situation.
my comments are inline below.
Best,
Andy

On Thu, Mar 17, 2016 at 2:23 AM, <[email protected]> wrote:

*Dear Andy and Robert, Thanks for your suggestions. Therefore, on one
hand, I have tried with; 1) echo $RAYPATH . : /usr/local/bin/radiance/lib
2) sudo echo $RAYPATH . : /usr/local/bin/radiance/lib (The outputs are the
same)*

*Then I wonder why the files are found when you run with sudo but not
found without sudo. Or am I mis-understanding what is going on.*

*3) urtza@urtza-VirtualBox:/usr/local/bin/radiance/lib$ ls There appear
all Radiance data files and GenericTranslucent20.dat and rang.cal as well
(The programs are in urtza@urtza-VirtualBox:/usr/local/bin/radiance/bin$ ,
and I think that I have to remove from "bin" directory
GenericTranslucent20.dat and rang.cal, which appears there as well)*

*this doesn't help, you need to use the -l (lowercase L) option with ls,
as I orginally suggested, to report the file and directory permissions. And
it would help if you did it for every directory in the path. like this:*

*ls -l /usr/local/bin/radiance/bin*
*ls -l /usr/local/bin/radiance*
*ls -l /usr/local/bin/*
*ls -l /usr/local/bin/radiance/lib*

*I do not know if I have problems with the installation, but I will not
use sudo for user level commands. On the other hand, (I have changed that
material for other one and I have launched dctimestep). The .xml file,
which they have lent for my PhD, is obtained by goniophotometer. 1) Ubuntu
14:*
*dctimestep -n 8760 photocells.vmx Film3M_145x1297_9142012_t.xml
southeast.dmx Barcelona.smx > illum.dat*

*Usage: dctimestep DCspec [tregvec]*
* or: dctimestep Vspec Tbsdf.xml Dmat.dat [tregvec]*

*2) Windows 8: dctimestep photocells.vmx Film3M_145x1297_9142012_t.xml
southeast.dmx Barcelona.smx > illum.dat fatal - unexpected column count in
header I checked with others files that I got and this files seem similar. *

*The tutorial is outdated. dctiemstep no longer accepts the -n 8760
option. This info is now contained in the matrix headers. run it again
without -n.*

*Thank you very much in advance. Best regards for you, Urtza. *

*Andy McNeil <[email protected] <[email protected]>>
escribió:*

*It could be that the directory is not in your RAYPATH, but it is in the
RAYPATH for root. *

*Try:*
*echo $RAYPATH*
*sudo echo $RAYPATH*

*Are there any differences in the output?*

*Also, it could be that your user doesn't have read permission in the
directory containing the files. Try using ls -l on every directory in the
path to find out (both lower case L). *

*As a last resort, I'd copy the files to the working directory, change
the owner, permissions, and add "." to RAYPATH. I agree with Lars that I'd
never use sudo to run user level commands. *

*Andy*

*On Mar 16, 2016, at 4:23 AM, [email protected]
<[email protected]> wrote: *

*Dear Andy, I have tried with; sudo chmod 664 GenericTranslucent20.dat
sudo chmod 664 rang.cal*

*sudo chmod 644 GenericTranslucent20.dat sudo chmod 644 rang.cal*

*sudo chmod 600 GenericTranslucent20.dat sudo chmod 600 rang.cal sudo
chmod 700 GenericTranslucent20.dat sudo chmod 700 rang.cal and the padlock
continues anyway (The files there are in /usr/local/bin/radiance/bin/ and
/usr/local/bin/radiance/lib/, as well). I have tried with rcontrib and it
scripts this anyway: *
*rcontrib -f /usr/share/radiance/klems_int.cal -b
'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2 -ad
512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells1.vmx*

*rcontrib: fatal - cannot find data file "GenericTranslucent20.dat" I do
not know what happen but I will continue finding an error (that padlock is
very strange). Thank you very much. Best regards, Urtza.*

*[email protected] <[email protected]> escribió:*

*Dear Andy, Thank you very much for your instructions. I will try with
them. Best regards, Urtza. Andy McNeil <[email protected]
<[email protected]>> escribió:*

*Urtza,*
*Here's some more information on file ownership and permissions for
linux:*
*http://linuxcommand.org/lc3_lts0090.php
<http://linuxcommand.org/lc3_lts0090.php>*
*Andy*

*On Tue, Mar 15, 2016 at 11:23 AM, Andy McNeil <[email protected]
<[email protected]>> wrote:*

*Urtza,*

*You should open up permissions on those two files like so:*

*sudo chmod 664 GenericTranslucent20.dat*
*sudo chmod 664 rang.cal*

*This changes permissions to allow owner and group read/write and
everyone read.*
*(you need to be in the directory or give the full path to the file).*

*Andy*

*On Tue, Mar 15, 2016 at 9:19 AM, <[email protected]
<[email protected]>> wrote:*

*Dear Lars, Thank you very much for your reply. I tried with
Five-Phase method earlier and all command worked. However, now I exported
the model from Rhino and I have some materials that they need two specific
files. I do not why they do not run without sudo, placing where there are
others, as well (They keep always the padlock, I copy there from DIVA's
files. They are not from radiance package previously installed). I use
oconv, rtrace and rpict with sudo and they work without problem.
Nervertheless, if using sudo is not good I remove those materials and I
could use rcontrib without sudo. Thank you for your suggestions. I read
Axel Jacob's tutorials but rereading will be fine. Best regards for you,
Urtza. "Lars O. Grobe" <[email protected] <[email protected]>> escribió:*

*Dear Urtza, two comments on your installation - this should be solved
before you even start using a complicated combination of commands such as
the three-phase method. First, with a correct configuration of your system
you will not need to run rcontrib as super-user (sudo). Your regular user
account just needs read-access to the .dat and .cal files in this case, so
why would you not grant the proper permissions? Second, as rcontrib is not
found, what makes you think it is installed? Did you install Radiance from
sources, did the build complete without errors, and did you include the
directory containing the binaries in your PATH environment variable? Does
any other Radiance command work for you? I would recommend having a look at
Axel Jacob's set of tutorials first, including the unix-introduction.
Otherwise you risk messing up a lot of your models with work-arounds, and
even risk the integrity of your system by using sudo where it should
definitively not be applied. Cheers, Lars. *

*Dear experts, I am trying with Three-Phase Method for Simulating
Complex Fenestration, following A McNeil tutorial. I am using Ubuntu 14 OS.
I need use sudo command because I have GenericTranslucent20.dat material
and rang.cal that they are locked anyway. However, when I have launched
sudo rcontrib, it scripts that: *

*sudo rcontrib -f /usr/share/radiance/klems_int.cal -b
'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2 -ad
512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells.vmx*

*sudo: rcontrib: command not found Could someone say what the problem
is? Thank you in advance. Best regards, Urtza.*

*_______________________________________________ Radiance-general
mailing list [email protected]
<[email protected]>
http://www.radiance-online.org/mailman/listinfo/radiance-general
<http://www.radiance-online.org/mailman/listinfo/radiance-general> *

*_______________________________________________ Radiance-general mailing
list [email protected]
<[email protected]>
http://www.radiance-online.org/mailman/listinfo/radiance-general
<http://www.radiance-online.org/mailman/listinfo/radiance-general>*

*_______________________________________________ Radiance-general mailing
list [email protected]
<[email protected]>
http://www.radiance-online.org/mailman/listinfo/radiance-general
<http://www.radiance-online.org/mailman/listinfo/radiance-general>*

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

Dear Andy,
Thank you very much for all suggestions.
I will try to follow your indications.
Best regards,
Urtza.

---- Andy McNeil escribió ----

···

Enviado desde mi smartphone Sony Xperia™

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

Hi Urtza and Andy,

I am having the same issue as you do Urtza, I have already checked the
headers of my view matrix, daylight matrix and sky matrix, and that doesn't
seem to be the problem, my view matrix is a 6X145, the daylight matrix a
145X2306, and finally, the sky matrix is a 2306X8760, and this info is on
the headers of each.

I think the problem is in the sky matrix file itself, it's not being
properly written.

Mine looks like this:
#?RADIANCE
gendaymtx -m 4 weather/lisboa.wea
LATLONG= 38.73000000 -9.15000000
NROWS=2306
NCOLS=8760
NCOMP=3
FORMAT=ascii

0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0.477 0.477 0.477
1.85 1.85 1.85
4.85 4.85 4.85
11.6 11.6 11.6
10.5 10.5 10.5
...

So it doesn't have the number of columns it should, i think that each row
has the RGB value for one patch of one time step and it should have the RGB
values for all time steps of one patch, is that it?

Best regards
Humberto A.

Hi Urtza and Andy,

I am having the same issue as you do Urtza, I have already checked the
headers of my view matrix, daylight matrix and sky matrix, and that doesn't
seem to be the problem, my view matrix is a 6X145, the daylight matrix a
145X2306, and finally, the sky matrix is a 2306X8760, and this info is on
the headers of each.

I think the problem is in the sky matrix file itself, it's not being
properly written.

Mine looks like this:
#?RADIANCE
gendaymtx -m 4 weather/lisboa.wea
LATLONG= 38.73000000 -9.15000000
NROWS=2306
NCOLS=8760
NCOMP=3
FORMAT=ascii

0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0.477 0.477 0.477
1.85 1.85 1.85
4.85 4.85 4.85
11.6 11.6 11.6
10.5 10.5 10.5
...

So it doesn't have the number of columns it should, i think that each row
has the RGB value for one patch of one time step and it should have the RGB
values for all time steps of one patch, is that it?

Best regards
Humberto A.

···

2016-03-20 13:42 GMT+00:00 Urtza Uriarte <[email protected]>:

Dear Andy,
Thank you very much for all suggestions.
I will try to follow your indications.
Best regards,
Urtza.

Enviado desde mi smartphone Sony Xperia™

---- Andy McNeil escribió ----

Hi Urtza,

glad your materials are finally working.
The most common cause of the error you are receiving is not having the
number of rows in your view matrix. You can use getinfo to look at the
header of your view matrix like this:
getinfo photocells.vmx

is there a line starting with NROWS=

If not, then you can use a text editor to add NROWS=10 (replace 10 with
your number of sensor points). This can be added in the rcontrib command
by adding -y 10

This is one of the many changes in radiance that makes the three phase
tutorial outdated. Sorry.

Andy

On Fri, Mar 18, 2016 at 4:56 AM, <[email protected]> wrote:

Dear Andy,

Thank you very much. Lars's and yours permission suggestions have helped
me.
I checked the directories by ls -l :
Every files have "-rwxrwxrwx 1 root root" permission description except
GenericTranslucent20.dat and rang.cal files; "-rwx------ 1 root root.
I changed the permission by "sudo chmod 777 file" and now the two files
have the same permission as others.
(plugins and /usr/local/bin/radiance and /usr/local/bin/radiance have
"drwxrwxrwx 3 root root" description)

I have launched and now it works. Thanks.
(Note that, I put this two files in my folder with padlock and then I run
with sudo and it works but with rcontrib no. Now, it seems that I put
everything ok and I do not need to do that, which could be not good)

Regarding dctimestep, I remove -n 8760 parameter but it seems that I have
problems with Sky Matrix. The steps have been these:

epw2wea ESP_Barcelona.081810_IWEC.epw Barcelona.wea
place BARCELONA_ESP
latitude 41.28
longitude -2.07
time_zone -15.00
site_elevation 6.0
weather_data_file_units 1

gendaymtx -m 4 Barcelona.wea > Barcelona.smx

dctimestep photocells.vmx Film3M_145x1297_9142012_t.xml southest.dmx
Barcelona.smx > illum.dat
fatal - unexpected EOF reading Barcelona.smx

I would be very grateful if you could find the problem. Thank you very
much in advance.
Best regards,
Urtza.

Andy McNeil <[email protected]> escribió:

Hi Urtza,
I'm having trouble following what errors we're debugging. Are you okay
not using those materials, because with minimal effort you should be able
to fix it. If you look at the links Lars and I sent you can learn about
permissions and fix the padlock situation.
my comments are inline below.
Best,
Andy

On Thu, Mar 17, 2016 at 2:23 AM, <[email protected]> wrote:

*Dear Andy and Robert, Thanks for your suggestions. Therefore, on one
hand, I have tried with; 1) echo $RAYPATH . : /usr/local/bin/radiance/lib
2) sudo echo $RAYPATH . : /usr/local/bin/radiance/lib (The outputs are the
same)*

*Then I wonder why the files are found when you run with sudo but not
found without sudo. Or am I mis-understanding what is going on.*

*3) urtza@urtza-VirtualBox:/usr/local/bin/radiance/lib$ ls There appear
all Radiance data files and GenericTranslucent20.dat and rang.cal as well
(The programs are in urtza@urtza-VirtualBox:/usr/local/bin/radiance/bin$ ,
and I think that I have to remove from "bin" directory
GenericTranslucent20.dat and rang.cal, which appears there as well)*

*this doesn't help, you need to use the -l (lowercase L) option with ls,
as I orginally suggested, to report the file and directory permissions. And
it would help if you did it for every directory in the path. like this:*

*ls -l /usr/local/bin/radiance/bin*
*ls -l /usr/local/bin/radiance*
*ls -l /usr/local/bin/*
*ls -l /usr/local/bin/radiance/lib*

*I do not know if I have problems with the installation, but I will not
use sudo for user level commands. On the other hand, (I have changed that
material for other one and I have launched dctimestep). The .xml file,
which they have lent for my PhD, is obtained by goniophotometer. 1) Ubuntu
14:*
*dctimestep -n 8760 photocells.vmx Film3M_145x1297_9142012_t.xml
southeast.dmx Barcelona.smx > illum.dat*

*Usage: dctimestep DCspec [tregvec]*
* or: dctimestep Vspec Tbsdf.xml Dmat.dat [tregvec]*

*2) Windows 8: dctimestep photocells.vmx Film3M_145x1297_9142012_t.xml
southeast.dmx Barcelona.smx > illum.dat fatal - unexpected column count in
header I checked with others files that I got and this files seem similar. *

*The tutorial is outdated. dctiemstep no longer accepts the -n 8760
option. This info is now contained in the matrix headers. run it again
without -n.*

*Thank you very much in advance. Best regards for you, Urtza. *

*Andy McNeil <[email protected] <[email protected]>>
escribió:*

*It could be that the directory is not in your RAYPATH, but it is in the
RAYPATH for root. *

*Try:*
*echo $RAYPATH*
*sudo echo $RAYPATH*

*Are there any differences in the output?*

*Also, it could be that your user doesn't have read permission in the
directory containing the files. Try using ls -l on every directory in the
path to find out (both lower case L). *

*As a last resort, I'd copy the files to the working directory, change
the owner, permissions, and add "." to RAYPATH. I agree with Lars that I'd
never use sudo to run user level commands. *

*Andy*

*On Mar 16, 2016, at 4:23 AM, [email protected]
<[email protected]> wrote: *

*Dear Andy, I have tried with; sudo chmod 664 GenericTranslucent20.dat
sudo chmod 664 rang.cal*

*sudo chmod 644 GenericTranslucent20.dat sudo chmod 644 rang.cal*

*sudo chmod 600 GenericTranslucent20.dat sudo chmod 600 rang.cal sudo
chmod 700 GenericTranslucent20.dat sudo chmod 700 rang.cal and the padlock
continues anyway (The files there are in /usr/local/bin/radiance/bin/ and
/usr/local/bin/radiance/lib/, as well). I have tried with rcontrib and it
scripts this anyway: *
*rcontrib -f /usr/share/radiance/klems_int.cal -b
'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2 -ad
512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells1.vmx*

*rcontrib: fatal - cannot find data file "GenericTranslucent20.dat" I do
not know what happen but I will continue finding an error (that padlock is
very strange). Thank you very much. Best regards, Urtza.*

*[email protected] <[email protected]> escribió:*

*Dear Andy, Thank you very much for your instructions. I will try with
them. Best regards, Urtza. Andy McNeil <[email protected]
<[email protected]>> escribió:*

*Urtza,*
*Here's some more information on file ownership and permissions for
linux:*
*http://linuxcommand.org/lc3_lts0090.php
<http://linuxcommand.org/lc3_lts0090.php>*
*Andy*

*On Tue, Mar 15, 2016 at 11:23 AM, Andy McNeil <[email protected]
<[email protected]>> wrote:*

*Urtza,*

*You should open up permissions on those two files like so:*

*sudo chmod 664 GenericTranslucent20.dat*
*sudo chmod 664 rang.cal*

*This changes permissions to allow owner and group read/write and
everyone read.*
*(you need to be in the directory or give the full path to the file).*

*Andy*

*On Tue, Mar 15, 2016 at 9:19 AM, <[email protected]
<[email protected]>> wrote:*

*Dear Lars, Thank you very much for your reply. I tried with
Five-Phase method earlier and all command worked. However, now I exported
the model from Rhino and I have some materials that they need two specific
files. I do not why they do not run without sudo, placing where there are
others, as well (They keep always the padlock, I copy there from DIVA's
files. They are not from radiance package previously installed). I use
oconv, rtrace and rpict with sudo and they work without problem.
Nervertheless, if using sudo is not good I remove those materials and I
could use rcontrib without sudo. Thank you for your suggestions. I read
Axel Jacob's tutorials but rereading will be fine. Best regards for you,
Urtza. "Lars O. Grobe" <[email protected] <[email protected]>> escribió:*

*Dear Urtza, two comments on your installation - this should be solved
before you even start using a complicated combination of commands such as
the three-phase method. First, with a correct configuration of your system
you will not need to run rcontrib as super-user (sudo). Your regular user
account just needs read-access to the .dat and .cal files in this case, so
why would you not grant the proper permissions? Second, as rcontrib is not
found, what makes you think it is installed? Did you install Radiance from
sources, did the build complete without errors, and did you include the
directory containing the binaries in your PATH environment variable? Does
any other Radiance command work for you? I would recommend having a look at
Axel Jacob's set of tutorials first, including the unix-introduction.
Otherwise you risk messing up a lot of your models with work-arounds, and
even risk the integrity of your system by using sudo where it should
definitively not be applied. Cheers, Lars. *

*Dear experts, I am trying with Three-Phase Method for Simulating
Complex Fenestration, following A McNeil tutorial. I am using Ubuntu 14 OS.
I need use sudo command because I have GenericTranslucent20.dat material
and rang.cal that they are locked anyway. However, when I have launched
sudo rcontrib, it scripts that: *

*sudo rcontrib -f /usr/share/radiance/klems_int.cal -b
'kbin(-sqrt(.5),sqrt(.5),0,0,0,1)' -bn Nkbins -m windowglow -I+ -ab 2 -ad
512 -lw 2e-5 sc-vi3M_vmx.oct < sc-vi3M.pts > photocells.vmx*

*sudo: rcontrib: command not found Could someone say what the problem
is? Thank you in advance. Best regards, Urtza.*

*_______________________________________________ Radiance-general
mailing list [email protected]
<[email protected]>
http://www.radiance-online.org/mailman/listinfo/radiance-general
<http://www.radiance-online.org/mailman/listinfo/radiance-general> *

*_______________________________________________ Radiance-general
mailing list [email protected]
<[email protected]>
http://www.radiance-online.org/mailman/listinfo/radiance-general
<http://www.radiance-online.org/mailman/listinfo/radiance-general>*

*_______________________________________________ Radiance-general
mailing list [email protected]
<[email protected]>
http://www.radiance-online.org/mailman/listinfo/radiance-general
<http://www.radiance-online.org/mailman/listinfo/radiance-general>*

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

Hi Humberto,

Actually, your header and ASCII data look OK. Although some tools would put all the columns together in one humungous line with 8760x3, white space has no meaning here and gendaymtx output has a newline for each column entry with an extra empty line between rows.

If you run the "wc" command on your file, you should get something like:

  20202873 60601692 xxxxxxxxxxx lisboa.smx

I don't know what xxxxxxx will be, but some large number corresponding to the number of bytes in your file. The first two values may not be exactly this, but should be reasonably close. Otherwise, your file really is missing some data at the end.

If your numbers agree roughly with the above, please send me a gzip'ped copies of your lisboa.wea and the output (*.smx) file in a private e-mail and I will see if I can figure out what is going on.

Cheers,
-Greg

···

From: Humberto Antunes <[email protected]>
Subject: Re: [Radiance-general] sudo recontrib
Date: March 20, 2016 2:30:23 PM PDT

Hi Urtza and Andy,

I am having the same issue as you do Urtza, I have already checked the headers of my view matrix, daylight matrix and sky matrix, and that doesn't seem to be the problem, my view matrix is a 6X145, the daylight matrix a 145X2306, and finally, the sky matrix is a 2306X8760, and this info is on the headers of each.

I think the problem is in the sky matrix file itself, it's not being properly written.

Mine looks like this:
#?RADIANCE
gendaymtx -m 4 weather/lisboa.wea
LATLONG= 38.73000000 -9.15000000
NROWS=2306
NCOLS=8760
NCOMP=3
FORMAT=ascii

0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0.477 0.477 0.477
1.85 1.85 1.85
4.85 4.85 4.85
11.6 11.6 11.6
10.5 10.5 10.5
...

So it doesn't have the number of columns it should, i think that each row has the RGB value for one patch of one time step and it should have the RGB values for all time steps of one patch, is that it?

Best regards
Humberto A.

Following this up on the general mailing list...

The problem was the one Andy pointed out earlier, where the newer version of dctimestep doesn't want the "-n" option when the sky matrix has a header.

Regarding the new question (appearing below), using rmtxop in this way is indeed the simplest means to convert RGB irradiance to illuminance in lux.

Cheers,
-Greg

···

From: Humberto Antunes <[email protected]>
Subject: Re: dctimesteps
Date: March 20, 2016 6:04:36 PM PDT

I tried to run the command like that and it worked just fine, i got the same results as you did.

I was running the dctimestep command with the -n 8760 option, but this is not needed because the sky matrix already contains that info in the header, running it like you solved the issue.

Now there is just one thing remaining, to convert the RGB values from illum.dat file to illuminance values can i use the command below or is there a better way?

rmtxop -c 47.435 119.93 11.635 results/illum.dat> results/illum_final.dat

Note:
179*0.265=47.436
179*0.670=119.93
179*0.065=11.635

Best regards
Humberto A.

2016-03-21 0:01 GMT+00:00 Gregory J. Ward <[email protected]>:
Thanks, Humberto. I ran the following command:

  dctimestep photocells.vmx singleclear.xml south.dmx lisboa.smx > illum.dat

without complaint. I am attaching the result.

Are you sure you have a recent installation of dctimestep? What do you see when you run dctimestep with no arguments? You should get:

Usage: dctimestep [-n nsteps][-o ospec][-i{f|d|h}][-o{f|d}] DCspec [skyf]
   or: dctimestep [-n nsteps][-o ospec][-i{f|d|h}][-o{f|d}] Vspec Tbsdf Dmat.dat [skyf]

Cheers,
-Greg

From: Greg Ward <[email protected]>
Subject: Re: [Radiance-general] sudo recontrib
Date: March 20, 2016 2:47:23 PM PDT

Hi Humberto,

Actually, your header and ASCII data look OK. Although some tools would put all the columns together in one humungous line with 8760x3, white space has no meaning here and gendaymtx output has a newline for each column entry with an extra empty line between rows.

If you run the "wc" command on your file, you should get something like:

  20202873 60601692 xxxxxxxxxxx lisboa.smx

I don't know what xxxxxxx will be, but some large number corresponding to the number of bytes in your file. The first two values may not be exactly this, but should be reasonably close. Otherwise, your file really is missing some data at the end.

If your numbers agree roughly with the above, please send me a gzip'ped copies of your lisboa.wea and the output (*.smx) file in a private e-mail and I will see if I can figure out what is going on.

Cheers,
-Greg

From: Humberto Antunes <[email protected]>
Subject: Re: [Radiance-general] sudo recontrib
Date: March 20, 2016 2:30:23 PM PDT

Hi Urtza and Andy,

I am having the same issue as you do Urtza, I have already checked the headers of my view matrix, daylight matrix and sky matrix, and that doesn't seem to be the problem, my view matrix is a 6X145, the daylight matrix a 145X2306, and finally, the sky matrix is a 2306X8760, and this info is on the headers of each.

I think the problem is in the sky matrix file itself, it's not being properly written.

Mine looks like this:
#?RADIANCE
gendaymtx -m 4 weather/lisboa.wea
LATLONG= 38.73000000 -9.15000000
NROWS=2306
NCOLS=8760
NCOMP=3
FORMAT=ascii

0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0.477 0.477 0.477
1.85 1.85 1.85
4.85 4.85 4.85
11.6 11.6 11.6
10.5 10.5 10.5
...

So it doesn't have the number of columns it should, i think that each row has the RGB value for one patch of one time step and it should have the RGB values for all time steps of one patch, is that it?

Best regards
Humberto A.

Dear Andy and Greg,

(I am trying to follow Humberto's issue, as well)
I have added to View Matrix sensor points number (I notice that in Daylight
Matrix I have not had NROWS data and I have added NROWS=145). To sum up I
have; Sky Matrix, 2306x8760; Daylight Matrix, 145x2306; and View Matrix,
552x145. I launched dctimestep and it scripts the same error (fatal -
unexpected EOF reading Barcelona.smx).

In case, I review the Sky Matrix with "wc" and I get almost the number that
Greg suggested:

wc Barcelona.smx

20202874 60601692 213155298 Barcelona.smx

I do not know what is the problem with Sky Matrix (although it seems a
little estrange 2306x8760 data are in rows).
Thank you in advance,
Urtza.

"Gregory J. Ward" <[email protected]> escribió:

Following this up on the general mailing list...
  
  The problem was the one Andy pointed out earlier, where the newer
version of dctimestep doesn't want the "-n" option when the sky matrix
has a header.
  
  Regarding the new question (appearing below), using rmtxop in this way
is indeed the simplest means to convert RGB irradiance to illuminance in
lux.
  
  Cheers,
  -Greg

FROM: Humberto Antunes <[email protected]>
    SUBJECT: Re: dctimesteps
    DATE: March 20, 2016 6:04:36 PM PDT
    

I tried to run the command like that and it worked just fine, i got the
same results as you did.
     I was running the dctimestep command with the -n 8760 option, but
this is not needed because the sky matrix already contains that info in
the header, running it like you solved the issue.
     
     Now there is just one thing remaining, to convert the RGB values
from illum.dat file to illuminance values can i use the command below
or is there a better way?
     
     rmtxop -c 47.435 119.93 11.635 results/illum.dat>
results/illum_final.dat
     
     Note:
     179*0.265=47.436
     179*0.670=119.93
     179*0.065=11.635
     
     Best regards
     Humberto A.

     2016-03-21 0:01 GMT+00:00 Gregory J.

Ward <[email protected]>:

···

Thanks, Humberto. I ran the following command:
        
        dctimestep photocells.vmx singleclear.xml south.dmx lisboa.smx
> illum.dat
        
        without complaint. I am attaching the result.
        
        Are you sure you have a recent installation of dctimestep?
What do you see when you run dctimestep with no arguments? You should
get:
        
                 Usage: dctimestep [-n nsteps][-o
ospec][-i{f|d|h}][-o{f|d}] DCspec [skyf]
          or: dctimestep [-n nsteps][-o ospec][-i{f|d|h}][-o{f|d}]
Vspec Tbsdf Dmat.dat [skyf]

        
        Cheers,
        -Greg
        

FROM: Greg Ward <[email protected]>

   SUBJECT: Re: [Radiance-general] sudo recontrib

   DATE: March 20, 2016 2:47:23 PM PDT

   

Hi Humberto,
   
   Actually, your header and ASCII data look OK. Although some tools
would put all the columns together in one humungous line with 8760x3,
white space has no meaning here and gendaymtx output has a newline for
each column entry with an extra empty line between rows.
   
   If you run the "wc" command on your file, you should get something
like:
   
   20202873 60601692 xxxxxxxxxxx lisboa.smx
   
   I don't know what xxxxxxx will be, but some large number
corresponding to the number of bytes in your file. The first two
values may not be exactly this, but should be reasonably close.
Otherwise, your file really is missing some data at the end.
   
   If your numbers agree roughly with the above, please send me a
gzip'ped copies of your lisboa.wea and the output (*.smx) file in a
private e-mail and I will see if I can figure out what is going on.
   
   Cheers,
   -Greg

FROM: Humberto Antunes <[email protected]>

    SUBJECT: Re: [Radiance-general] sudo recontrib

    DATE: March 20, 2016 2:30:23 PM PDT

    

Hi Urtza and Andy,
     I am having the same issue as you do Urtza, I have already
checked the headers of my view matrix, daylight matrix and sky matrix,
and that doesn't seem to be the problem, my view matrix is a 6X145,
the daylight matrix a 145X2306, and finally, the sky matrix is a
2306X8760, and this info is on the headers of each.
     
     I think the problem is in the sky matrix file itself, it's not
being properly written.
     
     Mine looks like this:
           #?RADIANCE
      gendaymtx -m 4 weather/lisboa.wea
      LATLONG= 38.73000000 -9.15000000
      NROWS=2306
      NCOLS=8760
      NCOMP=3
      FORMAT=ascii
      
      0 0 0
      0.477 0.477 0.477
      1.85 1.85 1.85
      4.85 4.85 4.85
      11.6 11.6 11.6
      10.5 10.5 10.5

     ...
     
     So it doesn't have the number of columns it should, i think that
each row has the RGB value for one patch of one time step and it
should have the RGB values for all time steps of one patch, is that it?
     
     Best regards
     Humberto A.

Hi Urtza,

Are you running dctimestep with the "-n" option? If yes try to run it
without it. use:

dctimestep view.mtx daylight.mtx transmision.xml sky.mtx

For me this solved the problem, no need for the "-n 8760" option.

Hope it helps.

Best regards
Humberto A.

···

2016-03-21 11:16 GMT+00:00 <[email protected]>:

Dear Andy and Greg,

(I am trying to follow Humberto's issue, as well)
I have added to View Matrix sensor points number (I notice that in
Daylight Matrix I have not had NROWS data and I have added NROWS=145). To
sum up I have; Sky Matrix, 2306x8760; Daylight Matrix, 145x2306; and View
Matrix, 552x145. I launched dctimestep and it scripts the same error (fatal
- unexpected EOF reading Barcelona.smx).

In case, I review the Sky Matrix with "wc" and I get almost the number
that Greg suggested:

wc Barcelona.smx

20202874 60601692 213155298 Barcelona.smx

I do not know what is the problem with Sky Matrix (although it seems a
little estrange 2306x8760 data are in rows).
Thank you in advance,
Urtza.

"Gregory J. Ward" <[email protected]> escribió:

Following this up on the general mailing list...

The problem was the one Andy pointed out earlier, where the newer version
of dctimestep doesn't want the "-n" option when the sky matrix has a header.

Regarding the new question (appearing below), using rmtxop in this way is
indeed the simplest means to convert RGB irradiance to illuminance in lux.

Cheers,
-Greg

*From: *Humberto Antunes <[email protected]>
*Subject: *Re: dctimesteps
*Date: *March 20, 2016 6:04:36 PM PDT

I tried to run the command like that and it worked just fine, i got the
same results as you did.

I was running the dctimestep command with the -n 8760 option, but this is
not needed because the sky matrix already contains that info in the header,
running it like you solved the issue.

Now there is just one thing remaining, to convert the RGB values from
illum.dat file to illuminance values can i use the command below or is
there a better way?

rmtxop -c 47.435 119.93 11.635 results/illum.dat> results/illum_final.dat

Note:
179*0.265=47.436
179*0.670=119.93
179*0.065=11.635

Best regards
Humberto A.

2016-03-21 0:01 GMT+00:00 Gregory J. Ward <[email protected]>:

Thanks, Humberto. I ran the following command:

dctimestep photocells.vmx singleclear.xml south.dmx lisboa.smx >
illum.dat

without complaint. I am attaching the result.

Are you sure you have a recent installation of dctimestep? What do you
see when you run dctimestep with no arguments? You should get:

Usage: dctimestep [-n nsteps][-o ospec][-i{f|d|h}][-o{f|d}] DCspec [skyf]
   or: dctimestep [-n nsteps][-o ospec][-i{f|d|h}][-o{f|d}] Vspec Tbsdf
Dmat.dat [skyf]

Cheers,
-Greg

*From:* Greg Ward <[email protected]>

*Subject:* Re: [Radiance-general] sudo recontrib

*Date:* March 20, 2016 2:47:23 PM PDT

Hi Humberto,

Actually, your header and ASCII data look OK. Although some tools would
put all the columns together in one humungous line with 8760x3, white space
has no meaning here and gendaymtx output has a newline for each column
entry with an extra empty line between rows.

If you run the "wc" command on your file, you should get something like:

20202873 60601692 xxxxxxxxxxx lisboa.smx

I don't know what xxxxxxx will be, but some large number corresponding to
the number of bytes in your file. The first two values may not be exactly
this, but should be reasonably close. Otherwise, your file really is
missing some data at the end.

If your numbers agree roughly with the above, please send me a gzip'ped
copies of your lisboa.wea and the output (*.smx) file in a private e-mail
and I will see if I can figure out what is going on.

Cheers,
-Greg

*From:* Humberto Antunes <[email protected]>

*Subject:* Re: [Radiance-general] sudo recontrib

*Date:* March 20, 2016 2:30:23 PM PDT

Hi Urtza and Andy,

I am having the same issue as you do Urtza, I have already checked the
headers of my view matrix, daylight matrix and sky matrix, and that doesn't
seem to be the problem, my view matrix is a 6X145, the daylight matrix a
145X2306, and finally, the sky matrix is a 2306X8760, and this info is on
the headers of each.

I think the problem is in the sky matrix file itself, it's not being
properly written.

Mine looks like this:
#?RADIANCE
gendaymtx -m 4 weather/lisboa.wea
LATLONG= 38.73000000 -9.15000000
NROWS=2306
NCOLS=8760
NCOMP=3
FORMAT=ascii

0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0.477 0.477 0.477
1.85 1.85 1.85
4.85 4.85 4.85
11.6 11.6 11.6
10.5 10.5 10.5
...

So it doesn't have the number of columns it should, i think that each row
has the RGB value for one patch of one time step and it should have the RGB
values for all time steps of one patch, is that it?

Best regards
Humberto A.

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general