Strange filetype naming when redering with radiance

Dear users,

I hope this is the correct forum to post this question.

I have run stumble upon a strange problem rendering images with radiance.

I have made a simple file containing the different commands to be executed to render the images/data needed. When I execute this file (source xxx.cal) All the output files have a (?) added to the file type (e.g. grid.xyz? instead of grid.xyz). Furthermore I cannot use \ as line separation in my file anymore.

Does anyone have any experience with these types of errors?

Best regards

Per Haugaard

      Find din nye laptop på kelkoo.dk. Se de gode tilbud her - http://dk.yahoo.com/r/pat/mm

Hi!

I hope this is the correct forum to post this question.

I am not sure yet :wink:

I have made a simple file containing the different commands to be
executed to render the images/data needed. When I execute this file
(source xxx.cal) All the output files have a (?) added to the file type
(e.g. grid.xyz? instead of grid.xyz). Furthermore I cannot use \ as line
separation in my file anymore.

You seam to have some interesting naming convention... usually in
Radiance-world, files with the extension .cal contain the mathematical
description language used in Radiance e.g. by rcalc or to do
transformations of textures. These are interpreted only by Radiance
tools. However, it seems that you use this extension for scripting? What
shell do you use? This question is most probably a shell-related one,
not a Radiance-related one.

I am just not sure because of the file-extension...

CU Lars.

Hi Per,

Can you post the contents of your shell script? That way people might be able to provide more input.

Regards,

-Jack de Valpine

Per Haugaard wrote:

···

Dear users,

I hope this is the correct forum to post this question.

I have run stumble upon a strange problem rendering images with radiance.

I have made a simple file containing the different commands to be executed to render the images/data needed. When I execute this file (source xxx.cal) All the output files have a (?) added to the file type (e.g. grid.xyz? instead of grid.xyz). Furthermore I cannot use \ as line separation in my file anymore.

Does anyone have any experience with these types of errors?

Best regards

Per Haugaard

------------------------------------------------------------------------

Få en billig laptop. Se Kelkoos gode tilbud her <http://dk.yahoo.com/r/pat/mm>!

------------------------------------------------------------------------

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general
  
--
# Jack de Valpine
# president
#
# visarc incorporated
# http://www.visarc.com
#
# channeling technology for superior design and construction

Dear Lars, Jack and users,

I use the bash shell in Ubuntu.

Here is my simple scripting:

## Level 4
## make an illuminumce picture of the plane
cat grids/level_4.xyz | rtrace -I -ab 4 -aa 0.05 -ar 128 -ad 512 -as 256 -x 759 -y 1160 -af ambfiles/df.amb -fac octrees/sav55_DF_LT70-60.oct > images/grid2illum_level_4.pic

## Decrease the size of the picture
pfilt -1 -x /10 -y /10 images/grid2illum_level_4.pic > images/grid2illum_level_4_resized.pic

## calculate the daylight factor for the picture grid2illum_resized.pic
pcomb -e 'lo=li(1)/le(1)/10000*100' images/grid2illum_level_4_resized.pic > images/grid2illum_level_4_resized_df.pic

## falsecolor for the daylight factor picture grid2illum_resized_df.pic
falsecolor -i images/grid2illum_level_4_resized_df.pic -s 11 -n 5.5 -l "DF %" > images/grid2illum_level_4_resized_df_falsecolor.pic

## rm -f images/grid2illum_level_4.pic images/grid2illum_level_4_resized.pic

As mentioned in my prior mail the output of the first command is grid2illum_level_4.pic?

Any ideas? This does not happen when I enter other similar projects.

Best regards

Per

--- Den tors 8/10/09 skrev Jack de Valpine <[email protected]>:

···

Fra: Jack de Valpine <[email protected]>
Emne: Re: [Radiance-general] Strange filetype naming when redering with radiance
Til: [email protected], "Radiance general discussion" <[email protected]>
Dato: torsdag 8. oktober 2009 15.17

Hi Per,

Can you post the contents of your shell script? That way people might
be able to provide more input.

Regards,

-Jack de Valpine

Per Haugaard wrote:

        Dear users,

I hope this is the correct forum to post this question.

I have run stumble upon a strange problem rendering images with
radiance.

I have made a simple file containing the different commands to be
executed to render the images/data needed. When I execute this file
(source xxx.cal) All the output files have a (?) added to the file type
(e.g. grid..xyz? instead of grid.xyz). Furthermore I cannot use \ as
line separation in my file anymore.

Does anyone have any experience with these types of errors?

Best regards

Per Haugaard

         Få en billig laptop. Se Kelkoos gode tilbud her!
      
_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general
  
--
# Jack de Valpine
# president
#
# visarc incorporated
# http://www.visarc.com
#
# channeling technology for superior design and construction

      Trænger du til at se det store billede? Kelkoo giver dig gode tilbud på LCD TV! Se her http://dk.yahoo.com/r/pat/lcd

Hi Per,

I think that this is probably an issue relating to the scripting and not Radiance. I think that first thing to check is if there are carriage returns in the file (appearing as ^M), if so these need to be removed. What program are you using to create/edit your script? You should make sure that the editor is saving the files appropriately for Unix/Linux not DOS. You should be able to use the \ to continue a command to the next line without any problems....

Also you might want to add:

#!/bin/bash

to the head of your script. Then if you set the script file to be executable:

chmod u+x /scriptfilename/

you can run the script simply by typing its name at the command line rather than sourcing it.

-Jack

Per Haugaard wrote:

···

Dear Lars, Jack and users,

I use the bash shell in Ubuntu.

Here is my simple scripting:

## Level 4
## make an illuminumce picture of the plane
cat grids/level_4.xyz | rtrace -I -ab 4 -aa 0.05 -ar 128 -ad 512 -as 256 -x 759 -y 1160 -af ambfiles/df.amb -fac octrees/sav55_DF_LT70-60.oct > images/grid2illum_level_4.pic

## Decrease the size of the picture
pfilt -1 -x /10 -y /10 images/grid2illum_level_4.pic > images/grid2illum_level_4_resized.pic

## calculate the daylight factor for the picture grid2illum_resized.pic
pcomb -e 'lo=li(1)/le(1)/10000*100' images/grid2illum_level_4_resized.pic > images/grid2illum_level_4_resized_df.pic

## falsecolor for the daylight factor picture grid2illum_resized_df.pic
falsecolor -i images/grid2illum_level_4_resized_df.pic -s 11 -n 5.5 -l "DF %" > images/grid2illum_level_4_resized_df_falsecolor.pic

## rm -f images/grid2illum_level_4.pic images/grid2illum_level_4_resized.pic

As mentioned in my prior mail the output of the first command is grid2illum_level_4.pic?

Any ideas? This does not happen when I enter other similar projects.

Best regards

Per

--- Den *tors 8/10/09 skrev Jack de Valpine /<[email protected]>/*:

    Fra: Jack de Valpine <[email protected]>
    Emne: Re: [Radiance-general] Strange filetype naming when redering
    with radiance
    Til: [email protected], "Radiance general discussion"
    <[email protected]>
    Dato: torsdag 8. oktober 2009 15.17

    Hi Per,

    Can you post the contents of your shell script? That way people
    might be able to provide more input.

    Regards,

    -Jack de Valpine

    Per Haugaard wrote:

    Dear users,

    I hope this is the correct forum to post this question.

    I have run stumble upon a strange problem rendering images with
    radiance.

    I have made a simple file containing the different commands to be
    executed to render the images/data needed. When I execute this
    file (source xxx.cal) All the output files have a (?) added to
    the file type (e.g. grid.xyz? instead of grid.xyz). Furthermore I
    cannot use \ as line separation in my file anymore.

    Does anyone have any experience with these types of errors?

    Best regards

    Per Haugaard

    ------------------------------------------------------------------------

    Få en billig laptop. Se Kelkoos gode tilbud her
    <http://dk.yahoo.com/r/pat/mm>!

    ------------------------------------------------------------------------

    _______________________________________________
    Radiance-general mailing list
    [email protected]
    http://www.radiance-online.org/mailman/listinfo/radiance-general
      
    -- # Jack de Valpine
    # president
    #
    # visarc incorporated
    # http://www.visarc.com
    #
    # channeling technology for superior design and construction
              
------------------------------------------------------------------------

Få en billig laptop. Se Kelkoos gode tilbud her <http://dk.yahoo.com/r/pat/mm>!

------------------------------------------------------------------------

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general
  
--
# Jack de Valpine
# president
#
# visarc incorporated
# http://www.visarc.com
#
# channeling technology for superior design and construction