Spectral rendering demo: "picture too dark or too bright"

Hi Michael,

You may have hit the lower limit of what pfilt considers "non-black." Your light source values are so low that when multiplied by a small solid angle and surface reflectance, the average could be too small for pfilt to notice. If you use the "-1" option to pfilt, I don't think you will get this error.

Also, I would like to point you to the 2002 paper I wrote with Elena on tristimulus color approximations, in case you haven't seen it:

  http://www.anyhere.com/gward/papers/egwr02/index.html

Cheers,
-Greg

···

From: Michael Bannert <[email protected]>
Date: August 28, 2013 9:14:18 AM PDT

Dear Radiance community,

I would like to do spectral rendering with Radiance using the N-step algorithm (Ruppertsberg & Bloj, 2008, http://www.ncbi.nlm.nih.gov/pubmed/18411553 ). The idea is to model surface reflectance in terms of average radiance per waveband rather than RGB values.

I tried to run their demo code and I think I'm really close to reproducing their results :slight_smile: However, when I run their bash script, I cannot get rid of the following error:

"pfilt: picture too dark or too bright
pvalue: missing resolution"

I suspect that my definition of the light source is not processed properly in the scene description. (On the other hand it does NOT tell me that "no light source" has been found.) Anyway, there is nothing to see in the resulting image.

I created my light source using ies2rad, as described in that paper. It didn't work right away so I had to make a few adjustments. For example, no lamp type was specified in the original code. So I called ies2rad with the "-t default" option.

Here is the file that was created by ies2rad :

# ies2rad -p stimuli/radiance/hyperspectral/Ruppertsberg-BRM-2008/ -c 0.000387 0.000422 0.000435 -o mylight -t default
# Dimensions in meters
#<# light.ies
#<# <# lamps> <lumens per lamp> <candela multiplier>
#<# <# vertical angles> <# horizontal angles>
#<# <photometric type> <units>
#<# <width> <length> <height>
#<# <ballast factor> <length> <height>
# 75 watt luminaire, lamp*ballast factor = 1

void brightdata mylight_dist
4 flatcorr stimuli/radiance/hyperspectral/Ruppertsberg-BRM-2008/mylight.dat source.cal src_theta
0
1 121615

mylight_dist light mylight_light
0
0
3 0.000387 0.000422 0.000435

mylight_light ring mylight.d
0
0
8
  0 0 -0.00025
  0 0 -1
  0 0.006096

Any help would be greatly appreciated!

Best regards,
Michael

--
Michael Bannert, Dipl.-Psych.
Vision & Cognition Lab, Centre for Integrative Neuroscience, Univ. of Tübingen & BCCN Tübingen
Otfried-Müller-Str. 25, 72076 Tübingen, Germany
Phone: +49 - (0)7071 / 29 - 89031

Thanks for your replies!

Yes, the code ran without problems when using the "-1" option. But I still cannot see anything. I also tried larger light source values in the -c option of ies2rad command but that didn't help either.

Since that code was a supplement of the main article, I was actually expecting it to run a little bit more smoothly...

Best,
Michael

···

On Aug 28, 2013, at 6:47 PM, Greg Ward wrote:

Hi Michael,

You may have hit the lower limit of what pfilt considers "non-black." Your light source values are so low that when multiplied by a small solid angle and surface reflectance, the average could be too small for pfilt to notice. If you use the "-1" option to pfilt, I don't think you will get this error.

Also, I would like to point you to the 2002 paper I wrote with Elena on tristimulus color approximations, in case you haven't seen it:

  http://www.anyhere.com/gward/papers/egwr02/index.html

Cheers,
-Greg

From: Michael Bannert <[email protected]>
Date: August 28, 2013 9:14:18 AM PDT

Dear Radiance community,

I would like to do spectral rendering with Radiance using the N-step algorithm (Ruppertsberg & Bloj, 2008, http://www.ncbi.nlm.nih.gov/pubmed/18411553 ). The idea is to model surface reflectance in terms of average radiance per waveband rather than RGB values.

I tried to run their demo code and I think I'm really close to reproducing their results :slight_smile: However, when I run their bash script, I cannot get rid of the following error:

"pfilt: picture too dark or too bright
pvalue: missing resolution"

I suspect that my definition of the light source is not processed properly in the scene description. (On the other hand it does NOT tell me that "no light source" has been found.) Anyway, there is nothing to see in the resulting image.

I created my light source using ies2rad, as described in that paper. It didn't work right away so I had to make a few adjustments. For example, no lamp type was specified in the original code. So I called ies2rad with the "-t default" option.

Here is the file that was created by ies2rad :

# ies2rad -p stimuli/radiance/hyperspectral/Ruppertsberg-BRM-2008/ -c 0.000387 0.000422 0.000435 -o mylight -t default
# Dimensions in meters
#<# light.ies
#<# <# lamps> <lumens per lamp> <candela multiplier>
#<# <# vertical angles> <# horizontal angles>
#<# <photometric type> <units>
#<# <width> <length> <height>
#<# <ballast factor> <length> <height>
# 75 watt luminaire, lamp*ballast factor = 1

void brightdata mylight_dist
4 flatcorr stimuli/radiance/hyperspectral/Ruppertsberg-BRM-2008/mylight.dat source.cal src_theta
0
1 121615

mylight_dist light mylight_light
0
0
3 0.000387 0.000422 0.000435

mylight_light ring mylight.d
0
0
8
  0 0 -0.00025
  0 0 -1
  0 0.006096

Any help would be greatly appreciated!

Best regards,
Michael

--
Michael Bannert, Dipl.-Psych.
Vision & Cognition Lab, Centre for Integrative Neuroscience, Univ. of Tübingen & BCCN Tübingen
Otfried-Müller-Str. 25, 72076 Tübingen, Germany
Phone: +49 - (0)7071 / 29 - 89031

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

--
Michael Bannert, Dipl.-Psych.
Vision & Cognition Lab, Centre for Integrative Neuroscience, Univ. of Tübingen & BCCN Tübingen
Otfried-Müller-Str. 25, 72076 Tübingen, Germany
Phone: +49 - (0)7071 / 29 - 89031

Besides the larger values, are you sure your light source surfaces have their normals facing into the room?

-Greg

···

From: Michael Bannert <[email protected]>
Date: August 30, 2013 10:16:14 AM PDT

Thanks for your replies!

Yes, the code ran without problems when using the "-1" option. But I still cannot see anything. I also tried larger light source values in the -c option of ies2rad command but that didn't help either.

Since that code was a supplement of the main article, I was actually expecting it to run a little bit more smoothly...

Best,
Michael

On Aug 28, 2013, at 6:47 PM, Greg Ward wrote:

Hi Michael,

You may have hit the lower limit of what pfilt considers "non-black." Your light source values are so low that when multiplied by a small solid angle and surface reflectance, the average could be too small for pfilt to notice. If you use the "-1" option to pfilt, I don't think you will get this error.

Also, I would like to point you to the 2002 paper I wrote with Elena on tristimulus color approximations, in case you haven't seen it:

  http://www.anyhere.com/gward/papers/egwr02/index.html

Cheers,
-Greg

From: Michael Bannert <[email protected]>
Date: August 28, 2013 9:14:18 AM PDT

Dear Radiance community,

I would like to do spectral rendering with Radiance using the N-step algorithm (Ruppertsberg & Bloj, 2008, http://www.ncbi.nlm.nih.gov/pubmed/18411553 ). The idea is to model surface reflectance in terms of average radiance per waveband rather than RGB values.

I tried to run their demo code and I think I'm really close to reproducing their results :slight_smile: However, when I run their bash script, I cannot get rid of the following error:

"pfilt: picture too dark or too bright
pvalue: missing resolution"

I suspect that my definition of the light source is not processed properly in the scene description. (On the other hand it does NOT tell me that "no light source" has been found.) Anyway, there is nothing to see in the resulting image.

I created my light source using ies2rad, as described in that paper. It didn't work right away so I had to make a few adjustments. For example, no lamp type was specified in the original code. So I called ies2rad with the "-t default" option.

Here is the file that was created by ies2rad :

# ies2rad -p stimuli/radiance/hyperspectral/Ruppertsberg-BRM-2008/ -c 0.000387 0.000422 0.000435 -o mylight -t default
# Dimensions in meters
#<# light.ies
#<# <# lamps> <lumens per lamp> <candela multiplier>
#<# <# vertical angles> <# horizontal angles>
#<# <photometric type> <units>
#<# <width> <length> <height>
#<# <ballast factor> <length> <height>
# 75 watt luminaire, lamp*ballast factor = 1

void brightdata mylight_dist
4 flatcorr stimuli/radiance/hyperspectral/Ruppertsberg-BRM-2008/mylight.dat source.cal src_theta
0
1 121615

mylight_dist light mylight_light
0
0
3 0.000387 0.000422 0.000435

mylight_light ring mylight.d
0
0
8
  0 0 -0.00025
  0 0 -1
  0 0.006096

Any help would be greatly appreciated!

Best regards,
Michael

--
Michael Bannert, Dipl.-Psych.
Vision & Cognition Lab, Centre for Integrative Neuroscience, Univ. of Tübingen & BCCN Tübingen
Otfried-Müller-Str. 25, 72076 Tübingen, Germany
Phone: +49 - (0)7071 / 29 - 89031

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

--
Michael Bannert, Dipl.-Psych.
Vision & Cognition Lab, Centre for Integrative Neuroscience, Univ. of Tübingen & BCCN Tübingen
Otfried-Müller-Str. 25, 72076 Tübingen, Germany
Phone: +49 - (0)7071 / 29 - 89031

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general