(solved) Re: [off-list] pcond: error reading from pfilt process in fovimage

Just following up on the earlier issue Max was having with pfilt on Windows. It is unrelated to the pcond issue, and appears to be a shell issue. I've never heard of the "Power Shell" before, but it seems best avoided with Radiance, or anything that sends binary data to stdout.



Begin forwarded message:

From: Max D <lists@spacesustainers.org>
Subject: (solved) Re: [off-list] [Radiance-general] pcond: error reading from pfilt process in fovimage
Date: October 23, 2014 1:07:22 AM PDT
To: "Gregory J. Ward" <gregoryjward@gmail.com>
Cc: "Guglielmetti, Rob" <Robert.Guglielmetti@nrel.gov>, "Sadeghipour, Mostapha" <sadeghipour@gmail.com>, alstan@jakubiec.net
Reply-To: Max D <lists@spacesustainers.org>

That's it!!! Great find- tested it just now and with the regular cmd shell, it
works - that's also why there's no problem through batch files. Using
"Power"shell, the output is garbled. Seems like that one is, uh, less powerful
than the name implies..
Thanks a lot, glad this has been cleared up.

All the best,

"Gregory J. Ward" <gregoryjward@gmail.com> hat am 22. Oktober 2014 um 23:44

Hi Max,

I found a possibly useful link referring to the "PowerShell," which outputs
16-bit/character Unicode by default. It's possibly that the pfilt output is
being maliciously treated as ASCII and translated to Unicode. Horrors!