Rmtxop- double output weird behaviour


#1

Hi there,
I don´t know if it´s even possible, but just read the manpage of rmtxop that I should be able to have my output file as double or float also instead of ascii.
So I used command : " rmtxop -fd -c 47.4 119.9 11.6 ./option_0_standard_raw.dat > ./option_0_standard_fd.dat "

but what I get is just “points” - see pic below

anyone any idea ?
thank you in advance
Peter Z


#2

-fd gives you binary doubles, which is why it looks like that in a text editor.


#3

Hi Rob,

Thank you for the swift answer. Now I get it.
And is there a way to have ASCII or normal text output file with 2 decimals for example ?

Best
Peter Z


#4

As far as I can tell, the decimal precision of the output is fixed. I typically lean that out later in some final reporting step; this usually happens in a Ruby script for me, so a simple .round(2) or whatever does the trick.


#5

I see, that´s a clever way, thank you for the hint.

Best
Peter Z


#6

Also, avoid ASCII if at all possible. I saw your commands all looked UNIXy, so I figure you’re running on Mac or Linux, and thus the Radiance matrix handling programs like rmtxop would handle the float/double data without a problem. I’ve had problems trying to do the matrix stuff on Windows with non-ASCII data so I save in ASCII, but it’s horribly inefficient to store the data that way. Matrixes stored as floats are like 10% the size they are as ASCII.


#7

Hi Rob,
Yes, Linux :slight_smile:
Exactly that´s my point to reduce the file size turning the ASCII to something smaller.
but after rmtxop, when I try to run rcollate with the -fd or -ff option I´ve got a weird error message " zsh: segmentation fault (core dumped) " - which as far as I googled comes from zshell and it´s yelling cause it can´t read the file

Best
Peter Z


#8

Weird. Have you tried bash for the hell of it? Also make sure that all the i/o along the way is indeed in the same format.


#9

You should not get a segmentation violation from any Radiance program under normal operation. It would be helpful to me if you would put together a test case that would allow me to reproduce your error with sample input files and commands. The rcollate program operation is suprisingly complicated, and it’s possible there is a bug in there I haven’t run across.


#10

Hi Greg,
Can I send you 40GB of data ? :smiley:
I can zip it.

I´m running centOS7

Best
Peter Z


#11

You’ll have to post it somehow. I don’t know how Discourse handles large attachments, or what the policy is on those, but you can try attaching a zip file to your reply and see if that works. It has worked for other (smaller) data sets. Or, you can put it on DropBox and share a link.