Rfluxmtx for illuminance rendering


#1

Hi All,

I am trying to generate an illuminance rendering, instead of luminance rendering.

The code below can successfully give a luminance rendering, and I tried to add an “-i”, but it did not work.

vwrays -vf views/south.vf -x 400 -y 400 -pj 0.7 -c 9 -ff | rfluxmtx -ffc -v -n 16 vwrays -vf views/south.vf -x 400 -y 400 -d -c 9 -ab 4 -ad 10000 -lw 0.0001 -o matrices/dc/hdr/south%03d.hdr - skyDomes/skyglow.rad -i octrees/roomDC.oct


#2

Can you give us some more information? How did it fail? Did it not generate any output, or was there some other issue? Was there an error message? What did rfluxmtx output to stderr – I notice you included the “-v” option.


#3

Hi Greg,

When I included -i or -I+, Radiance/rcontrib keeyps running, but nothing was produced.

Tommy


#4

OK, but it’s difficult to conclude anything from this. Are the rcontrib processes running, using CPU, or are they stalled? What happens if you use “-n 1”? Can you put together a simple package of files and commands to reproduce the problem?


#5

You told me you solved your problem, but it would be helpful to tell everyone what you found.


#6

The code was right. I changed to a faster computer and let it run for a while, the results made sense. Just rendering illuminance took much longer time compared to luminance.