Re-2: Re: behavior of 3ds2mgf

Dear Jan,

thanks for the pointer. I am using Gentoo Linux on all my servers and they also have howtos about this topic. The warning is definitely an important one though...
I will first try to find a version of Radiance where 3ds2mgf still worked and compare the sources, then I will know if it's worth the effort. I am sure I have some old machine with gcc 3.* somewhere, I guess I will try that first.

Original Message processed by David.InfoCenter


Subject: Re: [Radiance-dev] Re: behavior of 3ds2mgf (08-Okt-2008 9:01)
From: Jan Wienold <[email protected]>
To: [email protected]

Dear Erwin,

I don't know if the gcc is really the problem - but if yes, see below an instruction how to build an older gcc version with a newer one. I use that for compiling esp-r- which also has trouble with gcc4.xx.

Then you have two gcc versions in parallel. Be careful while installing: you have to use the make bootstrap otherwise you can destroy your system (if you install it as root it replaces the existing libraries - I once destroyed my system with that....)
Before using programs compiled under gcc3.x, you have to set the library path to the related lib-path ( export LD_LIBRARYPATH=/opt/gcc33/lib or similar).

Good luck!


------------- Instruction to build an gcc 3.3.6, using gcc4.xx ---------------------------

Get gcc-core from from GCC Mirrors Page

Compiling GCC-3.3.6:

Untar the source then configure with:
./configure --prefix=/opt/gcc33 --program-suffix=-3.3
WARNING: Do NOT configure it with the default prefix! It is recommended to compile it with this prefix else you can damage your system!
Now compile it with make bootstrap and after that install it with make install.

Gregory J. Ward wrote:
Sorry, Erwin. I tried. It isn't easy for me to debug something using a compiler I don't have on a machine I don't have.


From: "Erwin Zierler" <[email protected]>
Date: October 7, 2008 9:56:34 PM PDT

I have tried your patch but it didn't change things really. Out of curiosity I compiled the current head on a 32bit machine (also under Linux) and I get the exact same behavior (using the original 3ds2mgf.c).
So I finally tried an older binary of 3ds2mgf (Radiance 3.6a) on the same system and this one works just fine. Unfortunatly I dont have the sources anymore to see what happens if I compile them
Somehow I get a feeling it might have to do with the gcc version I am using on all these systems nowadays:

# gcc --version
gcc (GCC) 4.1.2 (Gentoo 4.1.2 p1.1)

For all older compilations I am pretty sure I was still using gcc 3.*.
Just in case that helps.

Radiance-dev mailing list
[email protected]

Dipl.-Ing. Jan Wienold
Project Manager
Fraunhofer-Institut für Solare Energiesysteme
Thermal Systems and Buildings, Lighting and Daylighting
Heidenhofstr. 2, 79110 Freiburg, Germany
Phone: +49(0)761 4588 5133 Fax:+49(0)761 4588 9133
[email protected]

In office:
Mo,Tue: 8:30-18:00
We,Thu: 8:30-16:00
Fr: 8:30-15:30