RdotP: undefined variable

Hi all -

Can anyone tell me where RdotP lives?

I have a fresh build of Radiance, and when using BRTDfunc materials, rprict throws an error:
rpict: RdotP: undefined variable

oddly, rvu is just fine with everything…

I’m on Ubuntu 18.04 here, and I’ve tried a build with both the 5.2 official release and the latest HEAD. Quite likely I’ve fouled up a library somewhere? Any help is much appreciated.


I think you may need to update your version of rayinit.cal and make sure that rpict is finding it. If you have the same RAYPATH environment setting when running rpict and rvu, then it’s puzzling that one works and the other doesn’t.

The latest rayinit.cal can be found in the distribution or downloaded from here. You need to make sure it is the first one found in your RAYPATH set of directories.

Thank you Greg! it was rayinit.cal - however, not an upgrade but a downgrade that was needed… revisions 2.19 and 2.18 both threw the error, but with 2.17 rpict is happy again…

That’s odd. What does “rpict -version” return? Also, can you share your .cal file or whatever it is that is associated with the BRTDfunc material?

the BRTDfunc is just an optics2rad glass material.

For versioning, I had:
RADIANCE 5.2.dd0f8e38a7 NREL 2018-10-09 (based on RADIANCE 5.2 Official Release by LBNL)
and that wasn’t working with whatever version of rayinit.cal came with it - changing it to revision 2.17 worked.

I’ve now updated to the latest HEAD and rpict with RADIANCE 5.3a is happy with the latest rev. 2.19 of rayinit.cal

It’s quite possible (likely) I messed up my NREL install, but someone might want to check the rayinit.cal version in the NREL release?

We were having some issues with the github updates, and it’s possible that there was an inconsistent pul in that particular NREL release. I can’t even check right now because radiance-online.org seems to be down(!) along with the CVS server it hosts. Welcome to the holidays!