Rcontrib lesson rpict error


I am currently trying to do the rcontrib lesson but I keep getting an error with rpict and I don’t know how to fix it, this is what I’ve done so far:

$ cat skies/sky_overcast.mat!
$cat skies/sky.rad
$ objline objects/testroom.rad |psmeta \images/testroom.eps
$ convert -flatten images/testroom.eps +profile “icc” images/testroom.png
$ getinfo testroom_overcast.oct
$ cat image.opt
$ DIMS=600
$ vw="-x $DIMS -y $DIMS -vf views/back.vf"
$ rpict @image.opt $vw testroom_overcast.oct > images/rpict.hdr

Here is where I get the error:
rpict: fatal - command line error at ‘-n’

I would appreciate if anyone knows how to fix this :slight_smile:



What is in “image.opt”? Does it contain a ‘-n’ option? If so, that option is not supported by rpict, even though it is supported by the Unix verison of rvu.

Oh yes it actually contains a -n option, I just tried to erase that part (I’m not sure if I should replace it with something else though) but now I am getting another error that says rpict: fatal - (testroom_overcast.oct): not an octree

This was before on image.opt:
-ab 3
-ad 1024
-ar 256
-aa .1
-n 2
Now it doesn’t have the -n line, and this is what I have on testroom_overcast.oct:
oconv materials/testroom.mat objects/testroom.rad skies/sky_overcast.mat skies/sky.rad



How big is the file “testroom_overcast.oct”? It is possible for an octree to have an appropriate header, but if the oconv command did not complete successfully, then it may not contain any data. Does this octree work with other programs like rvu or rtrace? I would try re-running the oconv command that created it to see if there is an error at that stage.

Thanks! The problem was in testroom_overcast.oct, indeed the oconv command did not complete successfully and now that it’s fixed it’s working fine.