Problem with rfluxmtx

Hi list,
I am performing the daylight simulation in 5phase method. When I generate the direct view matrice for images in the direct solar part of the 3phase method, there is something weird with "rfluxmtx"for the first time. I tried the -I+ but it didn’t works. Besides, I typed the command line in the terminal. Any suggestion is appreciated!

The solution is here: Problem with rfluxmtx - #3 by Taoning_Wang1

Looks like you’re missing ‘-’ in front of your receiver object, as a place holder for the sender object from standard input. Not sure if you want -I+ for you luminance image though.

p.s.: frads library is intended for avoiding mistake like this. It tries to help you with setting up and running matrix-based methods, include 5-phase.

Thanks for your advice and I just ignored the hypen. And I will spend some time to learn about the frads and I hope it can relieve my work.

I have tried those way that you mentioned and they still didn’t work. The true reason is I ignored the ‘-’.

Yes, I forgot why that -i was there in the first place. Taoning’s response is the correct one.


Hi Taoning,
I installed the frads on linux and looked through the documents and ppt about it. I tried ‘mrad init’ but it reported some errors like this. And I don’t know the usage of some parameters in the command line. Besides, I am not clear about the use of frads. How to create the configuration file?Do I need to create some folders like ‘objects’ in anvance?How to select the simulation methods like 5phase?

Sorry, there is a bug in last pypi version (v0.2.1). You can upgrade/fix this with the latest code:

pip install -U git+

I think you are on the right track. The mrad init command creates a configuration file for you, where you can make further adjustment.

You need a folder to place all your objects files. By default, mrad looks into “Objects” folder in your current directory. If you use other folder names, you can use --objdir to change that.

In general, mrad will determine the appropriate method for you once you have all the necessary parameters set in the .cfg file, but you’ll need to set separate_direct parameter to True to use five-phase methods. Alternatively, you can force a certain method using the method parameter. You can look at this example configuration file for reference. And more relevant doc here.