Official Radiance 5.2 release


#1

Rob Guglielmetti of NREL, Dan Fuller of LBNL, and yours truly have put together a new official release of Radiance, version 5.2, available from the usual download point. The NREL installers may be found here.

Some of the major changes and bug fixes since the last official release are mentioned in my talk from last month’s workshop in Loughborough, here. The new additions to gendaylit and evalglare by Jan Wienold and Aicha Diakite are described in their talk.

Some brief highlights are listed below:

psketch program for stylized objects
new rmtxop operators
falsecolor improvements
rvu “origin” command
rtpict tool for parallel rendering
aBSDF primitive for peak extraction

Please post here or to radiance-dev if you run into any problems with the installers or the release.

P.S. An issue was discovered with the gendaylit man page. The ray/doc/man/man1/gendaylit.1 document did not get updated with the utility. The updated PDF version is available with the other man pages in the usual place. A direct link is here. The updated nroff source file is in the CVS repository here.


#2

#3

Thanks! A question - as I’m never sure which of these things are broken by Mac upgrades, and which could be installer errors, or user errors…

On Mac OS 10.13.5 when I run the NREL installer, I don’t get x11.hdi, x11h.hdi, x11meta, xglaresrc, ximage, or xshowtrace in my /usr/local/radiance/bin folder. That was just the few I noticed looking at the end of the directory listing comparing to the binaries from radiance-online. And although rvu is there, I get what I assume is a related error from rvu that X11 is not found and cannot start X11, even though X11 is working for non-radiance commands.


#4

Perhaps this is related to Christopher’s question. Since the big update to the CMake files, a number of people building Radiance on Linux have shown me errors where CMake attempts to build rvu with Qt rather than X11. I thought that X11 was the default for rvu on Mac/Linux. Has this changed?

Nathaniel


#5

Hmm, looks like we have an issue. Yay!

I seem to have the same issue with my install here. I’m not sure what “big update” you’re referring to, Nathaniel. The Qt-able rvu was introduced years ago, but perhaps with the upgrade to a newer Qt we (I) messed something up. I seem to get the error Chris is mentioning but only when I try to run rvu in a regular shell and have XQuartz running. If I use the shell that XQuartz spawns, it works.

Bummer. I will have to look into this, stay tuned.


#6

Interesting… It turns out if I run rvu (in regular Terminal or XQuartz terminal) by using the rad command with -o x11 I get the same error in both cases, but if I run rvu directly it works in both the regular Terminal and XQuartz terminal. Both do appear to open what I think is the Qt rvu (which I’ve never used before) instead of the regular classic rvu. So that partly explains one issue.

The other issue is that the ximage, etc. weren’t installed from the installer package.


#7

Hi Rob,

I was referring to the Jan. 8 update by you and Alex. I don’t compile on Mac/Linux frequently, so I didn’t notice anything at the time, but since that change propagated into the Accelerad and Daysim repos, I’ve gotten messages about both.

However, it sounds like my issue is a little different from Christopher’s, because you seem to be successfully compiling rvu with Qt for Mac. What I’ve been hearing are errors like this:

CMake Error at InstallRules/CMakeLists.txt:19 (get_target_property):
  get_target_property() called with non-existent target "Qt5::QGifPlugin".

Which is weird because as far as I can tell the CMake code shouldn’t try to use Qt if it’s not found. Maybe there’s a missing version check?

But anyway, it sounds as if Qt is now the default option for compiling rvu on Mac/Linux.

Nathaniel


#8

Yeah, sorry I figure that was the one you were referring to. Yeah that was an attempt to get CMake to be somewhat predictable on our VMs, and I think we need to fix that up a bit.


#9

The cmake scripts aren’t too bright, and will default to Qt if it is available on the system. :frowning:

Before I ran out of time to do anything with Radiance, I was working on improvements.


#10

I’d say it’s actually too bright for its own good. I’d also say it’s better
than nothing. We’ll fix it though.


#11

I’ve just tred the win installer, and tried following the tutorial,
and the command/file “objline” is missing.
is there an alternative to it for windows workflow, or am I missing something?


#12

Hi @Lilith, objline is a c-shell script. As far as I know, there is no Windows-based equivalent for that.


#13

Sarith is correct; there is a handful of tools in the Radiance toolbox that
are still csh scripts, and thus are not included in the Windows installer.


#14

This thread went quiet, but for system maintenance plans I wanted to confirm more explicitly… Is the plan for the next update to go back to ensuring x11 as the default during install? And that would fix the install of ximage, keep objview working since it seems to assume x11, and go back to the x11 version of rvu (and maybe other related things)?

For now the pre-compiled binaries are working for my rvu, objview, and ximage needs
https://www.radiance-online.org/download-install/radiance-source-code/latest-release

Thanks,
Chris


#15

Hi Chris,

Yeah sorry, It’s still in my inbox though! Haven’t forgotten about it, and it’s definitely still planned to fix up all thew build stuff to make everything a little more predictable and useable – most of which is centered around making the GUI stuff default to x11. We don’t have any explicit funding for this but I’m hoping to be able to do it when we add the testing and CI stuff, which I’ve started (and Greg has done a ton of work on).