Dear Group

Recently, I have encountered a problem with OCONV. As a note, I run the applicaiton from Windows. I should also note that the scene that I am attempting to compile is composed of approximately 200K non-instanced polygons. With the binaries that were compiled for Desktop Radiance, when using oconv, I recieve an error message in a separate dialog box outside of the shell that I am using (CYGIN BASH Shell) that reads, "Application Error The instruction at "0x00406266" referenced at "0x0796db94". The memory could not be read. I later decomposed my 1 scene file into 2 separate files. When I oconv'ed them separately, there was no problem. When I attampted to recombine them using the -i option, the same error message occured. I then attempted to use the latest version of RADIANCE binaries compiled for Windows via CYGWIN. Basically the same thing happened as in the Desktop Radiance version of the binaries with the exception that instead the error message being in a separate dialog box, the error was listed in BASH shell as "Segmentation Fault" with the stackdump listed into a separate file as:

Exception: STATUS_ACCESS_VIOLATION at eip=0040A1DE
eax=FFD6B441 ebx=FFFF49A2 ecx=0000FFF7 edx=00000177 esi=0000B506 edi=0005083F
ebp=0022F958 esp=0022F940 program=c:\Radiance\bin\oconv.exe
cs=001B ds=0023 es=0023 fs=0038 gs=0000 ss=0023
Stack trace:
Frame Function Args
0022F958 0040A1DE (0CA52130, 00410460, 00000000, 0CA4D524)
0022F978 0040A0BA (0005083F, 0A040824, 0A040824, 610C5D49)
0022FA38 004039D8 (615F1F08, 0A040824, 0A040824, 00000000)
0022FE68 00403665 (615F1F08, 610CB320, 610CB320, 00000001)
0022FEF0 004012D1 (00000006, 615F1F58, 0A040328, 0022FF24)
0022FF40 61007408 (610D1F58, FFFFFFFE, 00000030, 610D1E7C)
0022FF90 610076ED (00000000, 00000000, 80430D77, 00000000)
0022FFB0 0040EF02 (00401190, 037F0009, 0022FFF0, 77E97D08)
0022FFC0 0040103C (0022FAE0, 0022FADC, 7FFDF000, 0022E70C)
0022FFF0 77E97D08 (00401000, 00000000, 000000C8, 00000100)
End of stack trace

I have not try to oconv't the file with the Linux binaries yet. I wil try to this evening but I am expecting the same error to occur.

Firstly, does anyone know what is causing this problem? I am familiar with the oconv error messages. I know that my error did seize when I broke down the scene file. It seems to me that if I had to many objects, I would recieve the "Hash table overflow in fullnode" error message instead of a Segmentation fault. Also, for many of you who have much more experience with using Radiance than I do, what would be a good estimate of the maximum number of non-instanced polygons that could be compiled into an octree before the "Hash table overflow in fullnode" error would be reached.


Marcus D. Jacobs


Get MSN 8 Dial-up Internet Service FREE for one month. Limited time offer-- sign up now! http://join.msn.com/?page=dept/dialup

Hi Marcus,

As it turns out, the bug you discovered is related to the number of modifiers in your files rather than the number of polygons. You have over 114,000 uniquely named colorpict primitives in your input files. If you had named them all the same, this error would not have occured. There was a place in my hash table function where I was overflowing a signed integer on the secondary hashing scheme. This was quite easy to fix, and now oconv runs and produces a 63 Mbyte octree on your files with no trouble. I have included the fix on the HEAD distribution if you wish to download it (src/common/modobject.c).

Thanks for discovering this bug!


From: "" <marcdevon@msn.com>
Date: Mon Sep 29, 2003 1:22:51 PM US/Pacific

Dear Greg

Thank you for your help with this problem.

I knew the error messages would not really help unless someone else has encountered a similar problem in the past.

I will send you these files. I have broken the scene file down into 3 indivdual files along with the material file (house6.mt). This is the first of 3 emails due to the attachment limit set by my ISP. Together they will be about 5.5 Megs compressed (65 Megs uncompressed). As I said before, compiling them individually is no problem. The problem comes when I try to merge them. The following should be noted.

1. These files were generated by a scene converter that I wrote to translate POVRAY triangles and smoth_triangles into Radiance polygons. Even though I wrote and compiled the scene for the Windows environment, in the source code all end of line are terminated with a "\n". I do not believe that this will pose a problem for Radiance compiles because I did not explicetly add in any CR. Please let me know if there are any problems with this.

2. The POVRAY files were generated by an architectural software that I use called "Chief Architect". For some odd reason, they have many 0 area triangles in their POVRAY export. OCONV will let you know when you encounter this. I'll add a feature to my converter that will calculate the area of all of the triangles to determine which ones should be written to the *.rad output file. However, I have been able to compile and render previous scene despite this flaw.

Please let me know if you can find out any information about this. Once again, thank you for your help.

Marcus D. Jacobs