Missing #?RADIANCE

I’m running rpict using the -S option to generate multiple images with different views. For some reason, the output HDR files (except for the first one) are missing #?RADIANCE in the header. The first line is FRAME=#. Is this a bug? A feature? I use Picturenaut to open the files, and it’s telling me that the format is not recognized.

It’s a bug! I wasn’t flushing the header storage in every case -S option is present with -o. Seems to have been there from the beginning, probably unnoticed because I usually use the persist mode (-P or -PP) with the -S option. Just checked in a fix.