Installation of Accelerad

Hi @Nathaniel_Jones,
I tried to install Accelerad again on Ubuntu cause I updated the nvidia driver. Firstly, I moved the unpacked folder to /usr/local and then the file ~/.bashrc is edited like this:

There occurred an error about the shared library when I test the .sh file in the demo :

I am not sure about my installation process. Besides, I installed the Radiance with the same procedure and it works well. I hope you or anyone can supply any guidance or suggestions, thanks!

Sorry for the mistake when editing the LD_LIBRARY_PATH in the file ~/.bashrc.

Accelerad has been installed sucessfully!

The demo file can run successfully but the command line can’t work in the script.

vwrays -vf $views/south.vf -x 900 -y 900 -pj 0.7 -ff | accelerad_rcontrib -i -ab 1 -ad 1024 -lw 1.0e-6 -dc 1 -dt 0 -dj 0 -ffc -n 1 \
    `vwrays -vf $views/south.vf -x 900 -y 900 -d` -o $hdrIllSpace/hdr$p-$q/%04d.hdr -e MF:6 -f -b rbin -bn Nrbins \
    -m solar $octrees/glazing$p-$q/sun.oct

How about this problem?

Hi @lee,

If I understand what you are saying correctly, was found when using the demo file, but not when using your own script. The demo files don’t make any changes to your LD_LIBRARY_PATH, so if they work then your LD_LIBRARY_PATH should be set up correctly. Does your script modify LD_LIBRARY_PATH at all, such that the OptiX library would no longer be part of it?

Hi @Nathaniel_Jones,

That’s right. The command line didn’t work in the script.

The script is about the 5 phase method and it won’t modify LD_LIBRARY_PATH at all.

Hi @lee,

I’m not sure why the command would work in the demo script but not in the script that you wrote. Can you add echo $LD_LIBRARY_PATH to your script and to the demo file and check that they are the same? The library should be found in one of the listed folders, or otherwise the demo wouldn’t work.

Hi @Nathaniel_Jones,
The problem is solved by open a new terminal cause the new environment variables need to work in a new loaded shell environment. So the installation process is OK and we just should pay attention to a few details. :face_with_raised_eyebrow: