Input genBSDF command in cmd with false response

Hello everyone! Today when I run genBSDF command in cmd, there is false response. But for other commands, they work. Any ideas? Thanks a lot!

xform: cannot find file
Could not load Radiance input

This seems like a basic question – much more basic than your previous queries, so I am puzzled by it.

Can you offer more information, such as the exact command you used? Running “genBSDF” by itself expects a Radiance scene file on the standard input.


Hi Greg! I am puzzled too. I just input the command as usual, but it doesn’t work.

genBSDF -c 500 +f +b -r “-ab 10 -ad 1” -dim 1249 1251 -25 25 -80 0 -geom millimeter prism.rad > prism.xml

This is a command from the tutorial, which I use as a test.

I guess it may be a problem with RAYPATH environment variable, but I have already added it to the path.

Hi Greg! Problem solved. I referred to some of the topics, and added rad files’s working directory to RAYPATH environment variable. Before, I only added the radiance’s working directory.

1 Like