genBSDF error on Windows


#1

Hi all,

I’m running the newest version of Radiance (5.2) on Windows. Following McNeil’s genBSDF tutorial, there seems to be problems wrapping the BSDF data. I get the following error:

wrapBSDF: Klems data error from 'C:\Users\Mikkel\AppData\Local\Temp\genBSDF.g2iJeZ\tb.dat'
Could not wrap BSDF data

I tried installing an older Radiance version (5.0.a.12), which wrapped the BSDF data perfectly. From comparing the code of genBSDF in the two versions I’ve found that the problem occurs at the following line:

$cmd .= " $src | getinfo -";

By replacing getinfo with rcollate from the older version (shown below) I was able to run the newest version without problems.

$cmd .= " $src | rcollate -ho -oc 145";

I’ve tried using Linux without problems. Is this an error related to Windows?

Thanks,
Mikkel


#2

Hi Mikkel,

This is an unexpected problem, likely related to Windows. If you happened to save the file:

from your failed run, I would like to see it. All the rcollate command was doing in this case was removing the header, which is what “getinfo -” does. If these two commands are producing different outputs under Windows, then I’d like to understand why.

Cheers,
-Greg


#3

The file is completely empty. The same goes for the other files (rb.dat, tf.dat, rf.dat).


#4

Hmmm. It seems like getinfo is broken on your build. Can someone running 5.2 under Windows confirm this problem? Specifically, we need to see if:

getinfo - < test.mtx

produces output from an ASCII matrix input.


#5

I will test this tomorrow, ASAP.