Falsecolor.exe _ s-auto


I have converted falsecolor.pl to falsecolor.exe to make it work without Perlin installed in other computers. The problem is when I use -s auto option, it always scales the values between 0 and 1. However it should scale between 0 and max according to illuminance/luminance values. Could you please help me on this?

The log is like that: ‘phisto’ is not recognized as an internal or external command,
operable program or batch file. Btw, the original falsecolor.pl also creates same error.

Phisto is one of the C-shell programs that has yet to be converted over to Perl or something more portable. It’s a very short program, however, and should only take an hour or so to convert. I can probably work on that in the next week or so and fix this issue. Thanks for making us aware of it.


1 Like

See if you can get the below to work:


Thanks Greg, I just refreshed the Github mirror as well.

1 Like

Thank you. However, now the Tail command is not recognized which is specific to UNIX batch operations. There may be a basic tail.pl to replicate this UNIX feature. Thank you again.

Ah. Didn’t notice that. Easily fixed:


1 Like

Thank you for the amazing support, actually without phisto.pl, i have created another solution, but may not be as accurate as this one. I have just copied some of the lines in the “doextreme” part to the “scale auto” part, it worked as expected.

Btw, i have a problem with the max values, in an interior scene, “s auto” get the max values of the sky visible from the glass façade, then the interior is not false colored efficiently, since the values in the room are very low compared with the sky. Then you see just bluish colors inside. Is there a way to mask the sky values?

You can set the scale manually based on a maximum taken from the interior, or you can switch to a log scale with the -log option to handle the wider range.

1 Like

Thank you for your help and understanding, a last question, “s auto” always scale between a min 0 value and max, if I can change the min value of the scale, it would be wonderful for my specific purpose. Is that possible over falsecolor.pl?

The minimum of a linear scale will always be zero the way we wrote falsecolor. If you use a log scale, you specify the number of log units, and the minimum is this many orders of magnitude below the maximum.

I have just found a chance to try it, but it also doesn’t work properly. The error is like that:
The syntax of the command is incorrect.
Use of uninitialized value $LogLmax in exponentiation (**) at C:\Users\anarchitect\Desktop\DaylightAnalysisLast\falsecolor.pl line 132.

My apologies. Looks like I missed removal of the pipe (’|’) character in my edit. Try: