Falsecolor.exe and pcomb

is anyone else getting an error running falsecolor/falsecolor2/wxfalsecolor on windows?

At some point in the past year or so all of these programs stopped working and they all throw the same error (I don’t use windows very often), this also means that honeybee and other interfaces that use falsecolor are outputting images without legends:

         ^ divide by zero constant

This is part of the pcomb expression to create the legend, it seems that yres is not getting assigned with the -y option. What is weird is that when I call a similar expression with pcomb directly it works.

Ultimately I fixed the problem with a 5.1 version of pcomb (but same falsecolor programs, which are not included in the release), the bug seems to have been introduced in one of the 5.2.x releases.

pcomb -x 100 -y 200 -e "lo=1/yres" > test.pcd



This is the result of a bug I fixed in pcomb, actually, that then caused an exception in falsecolor. You can download the working version from CVS using this link. Unfortunately, the current Windows build picked up the new version of pcomb.c but still with the old (newly broken) version of falsecolor.
Incidentally, this is the first example of one of Rob Guglielmetti’s regression tests spotting a problem, and it was really helpful in tracking it down.

The latest NREL release (2.5.1) was in June; it should have been built with the fixed pcond and falsecolor. I was gonna post up a fresh batch for the Workshop here too. As you can see from this test runner output (on HEAD as of two days ago), our falsecolor test (FWIW) is passing on the Windows VM:

As you can also see from this output, our test suite is lean, but we hope to beef that up this fall! Anyway, thanks for the testing plug Greg, and look for a “Workshop release” RSN.

Hi Rob,
when are you building a new release? I have a new version of evalglare and gendaylit…
I can send it to Greg tomorrow morning.
see you next week!

Hi Jan!

OK, if you have new versions of those two items we should definitely wait
for them to get into the distribution. As soon as you send the source to
Greg and he commits it, I’ll force a refresh of the Git mirror and our CI
system will build and test everything. We do have an evalglare test in
the system. ASSuming it all goes well, we can make a new release right then.

And yes, looking forward to see you and everyone next week!!

I think my issue is that I (and diva/honeybee/wxfalsecolor) use either falsecolor2.exe or falsecolor.exe in our scripts, neither of which is included in radiance releases. This results in the pcomb/falsecolor mismatch. I’m a bit willfully ignorant when it comes to windows, but some people in my office rely on these windows based tools, so I don’t know how to run/compile perl scripts to make a new .exe out of falsecolor.pl. Is it possible to include a falsecolor.exe in the official release? or can anyone offer advice on compiling perl scripts in windows?

Yes, there are a couple of options. We looked at that for the NREL releases but in the end just included Perl in the OpenStudio installers. The “perl-to-executable” methodology is basically embedding an entire Perl interpreter in the script. So you end up with, if memory serves, a few MB of redundant Perl interpreter code pasted in to each perl script you want to convert. Some options are:


The latter is the one I tried way back when.

Thanks Rob,

And sorry everyone for what was a clear “let me google that for you” question. I ended up installing strawberry perl: http://strawberryperl.com/ and then used pp -o falsecolor.exe falsecolor.pl. it is an 8 mb file, so I see your reasoning.