error message "file coeff_perez.dat cannot be opened"

Hi Sotiris.

How did you install Radiance/gendaylit?

If you are on Linux and used a recent Debian package then see here:

The package maintainer forgot to include the file in the package. You can
try to install an older package or use the source from the official website
(see below).

If you use another system (OS X or Windows) you should check that your
RAYPATH environment variable is set. Then check that the file is not in the
folders listed in RAYPATH.

If you are sure that you don't have the file grab the Radiance source code
from here:

Extract the archive, search for the file and place it in one of the folders
listed in your RAYPATH. That should do it.



2011/5/4 Σωτήρης Παπαντωνίου <[email protected]>

Hello everyone,

i am trying to use command gendaylit by i receive the following message:

# gendaylit 3 2 15 -a 42 -o 108 -W 100 100
file coeff_perez.dat cannot be opened
lect_coeff_perez does not work

file: "coeff_perez.dat" is not in the computer. Can you please give me
any solution??

Thank you very much


Hi Thomas,

I am running Ubuntu 11.04 and I installed Radiance through Synaptic package

So I suspect that you have installed the incomplete package.

I copied the “coeff_perez.dat” file but gendaylit again did not work
because it could not access “defangle.dat”

Yes. That too was mentioned in the post I pointed you to.

I have now download the source code from the site but when I copy the file

to /usr/share/radiance the file has an “X” on the top right of its image.

Can you be more specific, please. I assume you are neither familiar with a
Unix/Linux system nor the command line. I also assume that you have unpacked
the source package and copied the two files "coeff_perez.dat" and
"defangle.dat" to /usr/share/radiance.

Now, if you still get errors it might be related to the permissions of those
two files (which might be indicated by the "X" you are referring to). Open a
console window and type the commands

sudo chmod 644 /usr/share/radiance/coeff_perez.dat
sudo chown root:root /usr/share/radiance/coeff_perez.dat

After the first command you will have to provide your password to get the
required privileges.

With this your Radiance installation should be complete.



2011/5/11 Sotiris Papantoniou <[email protected]>

Not at all. This is how it is supposed to work.



On Wed, May 11, 2011 at 7:03 PM, Sotiris Papantoniou <[email protected] > wrote:

While I was trying to figure this out by myself I found that if I run
“gendaylit” command from the folder I have extracted the 2 files before
copying them to radiance folder the command works properly.

“Strange machines…”