Confused by GenSky

Hi Everyone,

It's been some time since I asked a dumb question of the clever people at radiance-general, so here goes...

I'm trying to render some scenes with varying illumination, in particular I want to vary the diffuseness of the illumination.

Currently I'm doing this with a hemi-field of spherical lights, with a non-homogenous density. This works fine for example <http://www.youtube.com/watch?v=zhsMeTtIPFA&list=HL1379509671&feature=mh_lolz>

However, that's for my made-up illumination, I need to confirm that what I'm doing bears any relationship to "real" illumination, i.e. using gensky with "+s", "-s" etc.

I've tried rendering the same scene while specifying the sun position using gensky, for example this works fine:

% Gensky settings: -ang 45 45 +s
%
% # C:\Program Files (x86)\MinGW-Radiance\bin\gensky -ang 45 45 +s
% # Ground ambient level: 14.8
%
% void light solar
% 0
% 0
% 3 6.77e+006 6.77e+006 6.77e+006
%
% solar source sun
% 0
% 0
% 4 -0.500000 -0.500000 0.707107 0.5
%
% void brightfunc skyfunc
% 2 skybr skybright.cal
% 0
% 7 1 9.56e+000 2.12e+001 5.71e-001 -0.500000 -0.500000 0.707107
%

However, when I try with the -s sky:

% Gensky settings: -ang 45 45 -s
%
% # C:\Program Files (x86)\MinGW-Radiance\bin\gensky -ang 45 45 -s
% # Ground ambient level: 14.8
%
% void brightfunc skyfunc
% 2 skybr skybright.cal
% 0
% 7 1 9.56e+000 2.12e+001 5.71e-001 -0.500000 -0.500000 0.707107

It just fails to render "pfilt: picture too dark or too bright ". The -c -u -i skies also don't render.

I'm running minGW radiance in windows (with a Matlab wrapper), the +s, -s, -c and -u skies work fine when I specify time and geographical location with gensky, but I want to specify the exact sun position.

Anyone have any suggestions?

best wishes,

George

Do you have a sky dome hemisphere definition in your scene such as the following? It would have to come after your gensky command in the scene.

skyfunc glow skyglow
0
0
4 1 1 1 0

skyglow source sky
0
0
4 0 0 1 180

However, when I try with the -s sky:

It just fails to render "pfilt: picture too dark or too bright ". The -c -u -i skies also don't render.

···

From: Paul Lovell [mailto:[email protected]]
____________________________________________________________
Electronic mail messages entering and leaving Arup business
systems are scanned for acceptability of content and viruses

Hi Christopher,

Yes, that gets tagged-on by another part of the wrapper (spaghetti code). My actual world.rad file contains this:-

···

*******************

# C:\Program Files (x86)\MinGW-Radiance\bin\gensky -ang 45 45 -s

# Ground ambient level: 14.8

void brightfunc skyfunc

2 skybr skybright.cal

0

7 1 9.56e+000 2.12e+001 5.71e-001 -0.500000 -0.500000 0.707107

skyfunc glow skyglow 0 0 4 1.00 1.00 1.00 0
skyglow source sky 0 0 4 0 0 1 180
void plastic white
0
0
5 0.5 0.5 0.5 0.0 0.2
********************

Other bits of the scene are represented in another file <the rectangular groundplane and horse).

You did direct me to one bug, my specified sky colour was ignored and [1 1 1] was always inserted. Luckily I've only ever used a [1 1 1] sky, thanks for fixing my future-bug.

George

________________________________
From: Christopher Rush [[email protected]]
Sent: 18 September 2013 14:54
To: Radiance general discussion
Subject: Re: [Radiance-general] Confused by GenSky

Do you have a sky dome hemisphere definition in your scene such as the following? It would have to come after your gensky command in the scene.

skyfunc glow skyglow
0
0
4 1 1 1 0

skyglow source sky
0
0
4 0 0 1 180

From: Paul Lovell [mailto:[email protected]]

However, when I try with the -s sky:

It just fails to render "pfilt: picture too dark or too bright ". The -c -u -i skies also don't render.

____________________________________________________________
Electronic mail messages entering and leaving Arup business
systems are scanned for acceptability of content and viruses

Have you tried adding a sky radiance level explicitly? I can't remember the correct option right now.

···

Paul Lovell <[email protected]> wrote:

Hi Everyone,

It's been some time since I asked a dumb question of the clever people
at radiance-general, so here goes...

I'm trying to render some scenes with varying illumination, in
particular I want to vary the diffuseness of the illumination.

Currently I'm doing this with a hemi-field of spherical lights, with a
non-homogenous density. This works fine for example
<http://www.youtube.com/watch?v=zhsMeTtIPFA&list=HL1379509671&feature=mh_lolz>

However, that's for my made-up illumination, I need to confirm that
what I'm doing bears any relationship to "real" illumination, i.e.
using gensky with "+s", "-s" etc.

I've tried rendering the same scene while specifying the sun position
using gensky, for example this works fine:

% Gensky settings: -ang 45 45 +s
%
% # C:\Program Files (x86)\MinGW-Radiance\bin\gensky -ang 45 45 +s
% # Ground ambient level: 14.8
%
% void light solar
% 0
% 0
% 3 6.77e+006 6.77e+006 6.77e+006
%
% solar source sun
% 0
% 0
% 4 -0.500000 -0.500000 0.707107 0.5
%
% void brightfunc skyfunc
% 2 skybr skybright.cal
% 0
% 7 1 9.56e+000 2.12e+001 5.71e-001 -0.500000 -0.500000 0.707107
%

However, when I try with the -s sky:

% Gensky settings: -ang 45 45 -s
%
% # C:\Program Files (x86)\MinGW-Radiance\bin\gensky -ang 45 45 -s
% # Ground ambient level: 14.8
%
% void brightfunc skyfunc
% 2 skybr skybright.cal
% 0
% 7 1 9.56e+000 2.12e+001 5.71e-001 -0.500000 -0.500000 0.707107

It just fails to render "pfilt: picture too dark or too bright ". The
-c -u -i skies also don't render.

I'm running minGW radiance in windows (with a Matlab wrapper), the +s,
-s, -c and -u skies work fine when I specify time and geographical
location with gensky, but I want to specify the exact sun position.

Anyone have any suggestions?

best wishes,

George

------------------------------------------------------------------------

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

--
Sent from my Android phone with K-9 Mail. Please excuse my brevity.

Hi Thomas,

I just tried: Gensky settings: -ang 45 45 -s -B 55.87

It works with +s [as it did before] but not with -s.

George

···

________________________________
From: Thomas Bleicher [[email protected]]
Sent: 18 September 2013 16:00
To: Radiance general discussion
Subject: Re: [Radiance-general] Confused by GenSky

Have you tried adding a sky radiance level explicitly? I can't remember the correct option right now.

Paul Lovell <[email protected]> wrote:
Hi Everyone,

It's been some time since I asked a dumb question of the clever people at radiance-general, so here goes...

I'm trying to render some scenes with varying illumination, in particular I want to vary the diffuseness of the illumination.

Currently I'm doing this with a hemi-field of spherical lights, with a non-homogenous density. This works fine for example <http://www.youtube.com/watch?v=zhsMeTtIPFA&list=HL1379509671&feature=mh_lolz>

However, that's for my made-up illumination, I need to confirm that what I'm doing bears any relationship to "real" illumination, i.e. using gensky with "+s", "-s" etc.

I've tried rendering the same scene while specifying the sun position using gensky, for example this works fine:

% Gensky settings: -ang 45 45 +s
%
% # C:\Program Files (x86)\MinGW-Radiance\bin\gensky -ang 45 45 +s
% # Ground ambient level: 14.8
%
% void light solar
% 0
% 0
% 3 6.77e+006 6.77e+006 6.77e+006
%
% solar source sun
% 0
% 0
% 4 -0.500000 -0.500000 0.707107 0.5
%
% void brightfunc skyfunc
% 2 skybr skybright.cal
% 0
% 7 1 9.56e+000 2.12e+001 5.71e-001 -0.500000 -0.500000 0.707107
%

However, when I try with the -s sky:

% Gensky settings: -ang 45 45 -s
%
% # C:\Program Files (x86)\MinGW-Radiance\bin\gensky -ang 45 45 -s
% # Ground ambient level: 14.8
%
% void brightfunc skyfunc
% 2 skybr skybright.cal
% 0
% 7 1 9.56e+000 2.12e+001 5.71e-001 -0.500000 -0.500000 0.707107

It just fails to render "pfilt: picture too dark or too bright ". The -c -u -i skies also don't render.

I'm running minGW radiance in windows (with a Matlab wrapper), the +s, -s, -c and -u skies work fine when I specify time and geographical location with gensky, but I want to specify the exact sun position.

Anyone have any suggestions?

best wishes,

George

________________________________

Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

--
Sent from my Android phone with K-9 Mail. Please excuse my brevity.

I assume you are rendering with -ab 1 or greater. Otherwise, the sky will never be sampled.

-Greg

···

From: Paul Lovell <[email protected]>
Date: September 18, 2013 8:20:53 AM PDT

Hi Thomas,

I just tried: Gensky settings: -ang 45 45 -s -B 55.87

It works with +s [as it did before] but not with -s.

George

From: Thomas Bleicher [[email protected]]
Sent: 18 September 2013 16:00
To: Radiance general discussion
Subject: Re: [Radiance-general] Confused by GenSky

Have you tried adding a sky radiance level explicitly? I can't remember the correct option right now.

Paul Lovell <[email protected]> wrote:
Hi Everyone,

It's been some time since I asked a dumb question of the clever people at radiance-general, so here goes...

I'm trying to render some scenes with varying illumination, in particular I want to vary the diffuseness of the illumination.

Currently I'm doing this with a hemi-field of spherical lights, with a non-homogenous density. This works fine for example <http://www.youtube.com/watch?v=zhsMeTtIPFA&list=HL1379509671&feature=mh_lolz>

However, that's for my made-up illumination, I need to confirm that what I'm doing bears any relationship to "real" illumination, i.e. using gensky with "+s", "-s" etc.

I've tried rendering the same scene while specifying the sun position using gensky, for example this works fine:

% Gensky settings: -ang 45 45 +s
%
% # C:\Program Files (x86)\MinGW-Radiance\bin\gensky -ang 45 45 +s
% # Ground ambient level: 14.8
%
% void light solar
% 0
% 0
% 3 6.77e+006 6.77e+006 6.77e+006
%
% solar source sun
% 0
% 0
% 4 -0.500000 -0.500000 0.707107 0.5
%
% void brightfunc skyfunc
% 2 skybr skybright.cal
% 0
% 7 1 9.56e+000 2.12e+001 5.71e-001 -0.500000 -0.500000 0.707107
%

However, when I try with the -s sky:

% Gensky settings: -ang 45 45 -s
%
% # C:\Program Files (x86)\MinGW-Radiance\bin\gensky -ang 45 45 -s
% # Ground ambient level: 14.8
%
% void brightfunc skyfunc
% 2 skybr skybright.cal
% 0
% 7 1 9.56e+000 2.12e+001 5.71e-001 -0.500000 -0.500000 0.707107

It just fails to render "pfilt: picture too dark or too bright ". The -c -u -i skies also don't render.

I'm running minGW radiance in windows (with a Matlab wrapper), the +s, -s, -c and -u skies work fine when I specify time and geographical location with gensky, but I want to specify the exact sun position.

Anyone have any suggestions?

best wishes,

George

Greg, thankyou!

A change I made in my wrapper a few weeks ago left out the ab setting, now it's back and it works.

Thanks everyone,

George

···

On 18/09/2013 17:00, Greg Ward wrote:

I assume you are rendering with -ab 1 or greater. Otherwise, the sky will never be sampled.

-Greg

*From: *Paul Lovell <[email protected] <mailto:[email protected]>>

*Date: *September 18, 2013 8:20:53 AM PDT

*

Hi Thomas,

I just tried: Gensky settings: -ang 45 45 -s -B 55.87

It works with +s [as it did before] but not with -s.

George

------------------------------------------------------------------------
*From:* Thomas Bleicher [[email protected]]
*Sent:* 18 September 2013 16:00
*To:* Radiance general discussion
*Subject:* Re: [Radiance-general] Confused by GenSky

Have you tried adding a sky radiance level explicitly? I can't remember the correct option right now.

Paul Lovell <[email protected] <mailto:[email protected]>> wrote:

    Hi Everyone,

    It's been some time since I asked a dumb question of the clever
    people at radiance-general, so here goes...

    I'm trying to render some scenes with varying illumination, in
    particular I want to vary the diffuseness of the illumination.

    Currently I'm doing this with a hemi-field of spherical lights,
    with a non-homogenous density. This works fine for example
    <http://www.youtube.com/watch?v=zhsMeTtIPFA&list=HL1379509671&feature=mh_lolz>

    However, that's for my made-up illumination, I need to confirm
    that what I'm doing bears any relationship to "real"
    illumination, i.e. using gensky with "+s", "-s" etc.

    I've tried rendering the same scene while specifying the sun
    position using gensky, for example this works fine:

    % Gensky settings: -ang 45 45 +s
    %
    % # C:\Program Files (x86)\MinGW-Radiance\bin\gensky -ang 45 45 +s
    % # Ground ambient level: 14.8
    %
    % void light solar
    % 0
    % 3 6.77e+006 6.77e+006 6.77e+006
    %
    % solar source sun
    % 0
    % 4 -0.500000 -0.500000 0.707107 0.5
    %
    % void brightfunc skyfunc
    % 2 skybr skybright.cal
    % 0
    % 7 1 9.56e+000 2.12e+001 5.71e-001 -0.500000 -0.500000 0.707107
    %

    However, when I try with the -s sky:

    % Gensky settings: -ang 45 45 -s
    %
    % # C:\Program Files (x86)\MinGW-Radiance\bin\gensky -ang 45 45 -s
    % # Ground ambient level: 14.8
    %
    % void brightfunc skyfunc
    % 2 skybr skybright.cal
    % 0
    % 7 1 9.56e+000 2.12e+001 5.71e-001 -0.500000 -0.500000 0.707107

    It just fails to render "pfilt: picture too dark or too bright ".
    The -c -u -i skies also don't render.

    I'm running minGW radiance in windows (with a Matlab wrapper),
    the +s, -s, -c and -u skies work fine when I specify time and
    geographical location with gensky, but I want to specify the
    exact sun position.

    Anyone have any suggestions?

    best wishes,

    George

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

--
Dr P. George Lovell,

Lecturer in Psychology
University of Abertay Dundee
Dundee
DD1 1HG

Tel 01382-308581
Fax 01382-308749

Researcher/Co-investigator,
School of Psychology, University of St Andrews

RM 2.27 (The Yellow Room).
Phone (01334) 463056