Accelerad zero-area polygon warnings

Hi all,

I am currently using Radiance, specifically GPU-based accelerad, for my solar irradiance simulation (from Python, using Honeybee). During execution I get many zero-area warning, such as:

accelerad_rcontrib: warning - zero area for polygon "temp_e728fcfc_337"

Although I have tried to remove these polygons in my preprocessing phase, I am still getting these errors unfortunately, I suspect due to differences in tolerances between Accelerad and my modelling software. Now I have read somewhere that it is not a huge problem to keep the zero-area polygons in the simulation, but it is not ideal for readability of stdout.

So my questions are:

  • Am I correct that it is not a problem to ignore the zero-area warnings?
  • Is there any way to hide the warnings for readability?

Thank you for your time!

Hi Stroesoe,

you are correct – zero area polygons can be ignored. The ‘official’ rcontrib has the -w option that disables those warnings. I am assuming you also have this switch in accelerad_rcontrib.

Also, if you are generating the rad polygon files from OBJs, it’s worth-while looking at the new robjutil command, which allows you to tidy up OBJs by removing degenerate faces etc.




Thanks @Axel_Jacobs2,

That’s very helpful! At least I now know it’s not a problem. Unfortunately though, I am not sure how to use this -w option in the workflow I am using.

Perhaps there are users here at the forum that are more familiar with the Honeybee Radiance workflow? I know that Honeybee calls an executable called queenbee.exe which calls Radiance somehow. Does anyone know if it is possible to change an argument such as -w from Python?


Hi @Stroesoe,

You can pass on -w to rcontrib by using the ‘radiance-parameters’ recipe input. Here is an example:

from lbt_recipes.recipe import Recipe

recipe = Recipe('name-of-recipe')
recipe.input_value_by_name('radiance-parameters', '-ab 3 -ad 5000 -w')