Why shadow are irregularity when using ripct to render?

I use rpict to render a daylit spaces with a window installed a blind. I used rpict to render it and found the shadow on the ground are irregularity. I also tried to bump up the -ad and reduce -aa , but even I set -aa as 0 to disable indirect cache, it has no improvement. But when use rpict, I got a very regular shadow.
Below are HDR images rendered by rpict and rtrace, respectively.
Left: rpict -vf Views/view.vf -x 600 -y 600 -aa 0.1 -dc 1 -dt 0 -dj 0 -lw 1e-3 -ab 5 -ad 1000
Right: rtrace -n 16 -vf Views/view.vf -x 600 -y 600 -aa 0.1 -dc 1 -dt 0 -dj 0 -lw 1e-3 -ab 5 -ad 1000

Is there anyway make rpict to produce a image whose shadow are regular.

The shadows are created by the direct calculation, so any change of any parameters on the ambient calculation will not help.
I guess it is the pixel sampling which should be set to 1 (-ps 1). In addition, I would recommend to lower -lw significantly otherwise the ray termination is too early (e.g. -lw 1e-6).
hope that helps

1 Like

You must be using “rtpict” not “rtrace” in your example. Jan is correct that the -ps option in rpict should be set to 1 to avoid image-plane sampling in this case. The rtpict command ignores the -ps option and always uses -ps 1 because it does not implement this feature, which saves time in many situations while producing reasonably accurate results. The indirect calculation is not the one with problems in your test.


Thanks for your reply @Greg_Ward @Jan_Wienold

Follow your guidance, the problem was solved.

In additon, sorry for my slip of pen. The HDR image on the right was definitely rendered by rtpict.