rpict -dv option to switch light source visibility

Hello everyone,

I tried to make light source invisible by using the -dv option in rpict,
but somehow it doesn't work for me. The lights are shown black.

In my case, the camera and lights are placed at the same height in a room,
and the camera is looking down towards the floor. I have tried both with
and without -dv option.

When I place camera just below the lights, then the lights are not visible
(which is obvious, as lights are then not in line of sight).

Has someone else also experienced the same? Thank you!

Best regards,
Vaib

Vaib

I think the -dv switch works as designed. It will not hide the light source
completely but the source itself is shown in black instead of the actual
brightness that the object (lamp, light fitting etc) would have. I think
that was done to avoid high intensity peaks that would confuse certain
evaluation algorithms in other applications.

In your case you should be able to hide the light sources using a clipping
plane. Check the -vo option of rpict.

Regards,
Thomas

···

On Sun, Feb 16, 2014 at 5:19 PM, Vaib <[email protected]> wrote:

Hello everyone,

I tried to make light source invisible by using the -dv option in rpict,
but somehow it doesn't work for me. The lights are shown black.

In my case, the camera and lights are placed at the same height in a room,
and the camera is looking down towards the floor. I have tried both with
and without -dv option.

When I place camera just below the lights, then the lights are not visible
(which is obvious, as lights are then not in line of sight).

Has someone else also experienced the same? Thank you!

Best regards,
Vaib

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

Thank you for correcting me Thomas.

Regards,
Vaib

···

On 17 February 2014 15:15, Thomas Bleicher <[email protected]> wrote:

Vaib

I think the -dv switch works as designed. It will not hide the light
source completely but the source itself is shown in black instead of the
actual brightness that the object (lamp, light fitting etc) would have. I
think that was done to avoid high intensity peaks that would confuse
certain evaluation algorithms in other applications.

In your case you should be able to hide the light sources using a clipping
plane. Check the -vo option of rpict.

Regards,
Thomas

On Sun, Feb 16, 2014 at 5:19 PM, Vaib <[email protected]> wrote:

Hello everyone,

I tried to make light source invisible by using the -dv option in rpict,
but somehow it doesn't work for me. The lights are shown black.

In my case, the camera and lights are placed at the same height in a
room, and the camera is looking down towards the floor. I have tried both
with and without -dv option.

When I place camera just below the lights, then the lights are not
visible (which is obvious, as lights are then not in line of sight).

Has someone else also experienced the same? Thank you!

Best regards,
Vaib

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general