Radiance within Mac OSX

hi, all~
i am a beginner to radiance as well as this mailing list. i got a problem that radiance cant work in my mac (OSX 10.6).
i have already installed it, and can run some simple command such as, ra_tiff. but everytime i run the command "rview", the compiler will complain that ""dyld: rview can't open library: /usr/X11R6/lib/libX11.6.dylib (No such file or directory, errno = 2)Trace/BPT trap""

but i am sure i have X11 support in my mac. so how can i do to let it work???

looking forward to your reply~~~many thanks~~~

P.S>i am sorry about any unconvenient due to my POOR english.

···

_________________________________________________________________
������� MSN Explorer: http://explorer.msn.com/lccn/

Hi!

radiance cant work in my mac (OSX 10.6).

Are you sure ? AFAIK the latest OS X is 10.3.6, is this the one you use? I guess you use the precompiled release? I have 3.6 compiled on 10.3 here, and everything is fine. Do you want to try my binaries for 10.3.x?

but i am sure i have X11 support in my mac. so how can i do to let it work???

Probably, if you use 10.3.x (did you use any other X11-apps in the past?).

P.S>i am sorry about any unconvenient due to my POOR english.

I think I am the one writing the worst English on this list - and you didn't have to HEAR me so far :wink:

CU Lars.

Thanks for reply.
the OS i used is OSX 10.3.6.
i use the precompiled release just as u said.
i installed the same version on Linux, and it works well.
in fact, i have no idea about the X11, but i installed the X11 support for mac before install radiance.
i am not quiet sure about wether i put the library file into a correct location.
could u plz send me a copy of your binaries for 10.3.x, and teach me how to get it work step by step? PLzzzzz.
if it could work in my loptop, i dont have to go to the lab everyday....:frowning:

···

radiance cant work in my mac (OSX 10.6).

Are you sure ? AFAIK the latest OS X is 10.3.6, is this the one you use? I guess you use the precompiled release? I have 3.6 compiled on 10.3 here, and everything is fine. Do you want to try my binaries for 10.3.x?

but i am sure i have X11 support in my mac. so how can i do to let it work???

Probably, if you use 10.3.x (did you use any other X11-apps in the past?).

P.S>i am sorry about any unconvenient due to my POOR english.

I think I am the one writing the worst English on this list - and you didn't have to HEAR me so far :wink:

CU Lars.

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

_________________________________________________________________
免费下载 MSN Explorer: http://explorer.msn.com/lccn/

Thanks for reply.
the OS i used is OSX 10.3.6.
i use the precompiled release just as u said.
i installed the same version on Linux, and it works well.
in fact, i have no idea about the X11, but i installed the X11 support for mac before install radiance.
i am not quiet sure about wether i put the library file into a correct location.
could u plz send me a copy of your binaries for 10.3.x, and teach me how to get it work step by step? PLzzzzz.
if it could work in my loptop, i dont have to go to the lab everyday....:frowning:

radiance cant work in my mac (OSX 10.6).

Are you sure ? AFAIK the latest OS X is 10.3.6, is this the one you use? I guess you use the precompiled release? I have 3.6 compiled on 10.3 here, and everything is fine. Do you want to try my binaries for 10.3.x?

but i am sure i have X11 support in my mac. so how can i do to let it work???

Probably, if you use 10.3.x (did you use any other X11-apps in the past?).

P.S>i am sorry about any unconvenient due to my POOR english.

I think I am the one writing the worst English on this list - and you didn't have to HEAR me so far :wink:

CU Lars.

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

_________________________________________________________________
~{Cb7QOBTX~} MSN Explorer: http://explorer.msn.com/lccn/

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

···

On Nov 28, 2004, at 2:42 PM, Shu Chunxiao wrote:

Hello,

Because of a conflict, the command "rview" has been renamed "rvu"

Try the new name and see if it works.

Matthew

···

On Nov 27, 2004, at 7:38 PM, ~{Jf~} ~{4:O~~} wrote:

hi, all~~
i am a beginner to radiance as well as this mailing list. i got a problem that radiance cant work in my mac (OSX 10.6).
i have already installed it, and can run some simple command such as, ra_tiff. but everytime i run the command "rview", the compiler will complain that ""dyld: rview can't open library: /usr/X11R6/lib/libX11.6.dylib (No such file or directory, errno = 2)Trace/BPT trap""

but i am sure i have X11 support in my mac. so how can i do to let it work???

looking forward to your reply~~~~~~many thanks~~~~~~

P.S>i am sorry about any unconvenient due to my POOR english.

_________________________________________________________________
~{Cb7QOBTX~} MSN Explorer: http://explorer.msn.com/lccn/

_______________________________________________
Radiance-general mailing list
[email protected]
http://www.radiance-online.org/mailman/listinfo/radiance-general

Hi!

Because of a conflict, the command "rview" has been renamed "rvu"

That's true, however, if this was the problem, he should simply get the wrong program (vi) started, no such error message.

""dyld: rview can't open library: /usr/X11R6/lib/libX11.6.dylib (No such file or directory, errno = 2)Trace/BPT trap""

By the way, did you check if this library exists on your system? Try: ls /usr/X11R6/lib/libX11.6.*

The file is there on my OS X 10.3.6 machine and should be installed if you have X11-support!

One more hint, you can perfectly remote-control linux- and other ix-machines from your OS X laptop using ssh, even X11-windows can be redirected to your laptop. IMHO it's better to use "real" computers for large renderings, I don't like to overheat my laptop by having 100% cpu for hours...

I will make some 3.6 binaries and provide them on my binary-pages as soon as I find the time.

CU Lars.