Radiance-general digest, Vol 1 #389 - 30 msgs


I also picked up Panther, and initially ran into the same problems you did.

I'm not sure what exactly fixed the problem, but here is what I did to get the install to run.

1) Install XCode (the developer's tools)
2) Download and extract radiance-HEAD.tgz
3) Download extract rad3R5supp.tar.gz
4) Copy the contents of rad3R5supp into the appropriate places into the content of radiance-HEAD
5) Run the makeall install script

So far, it seems as if the install went fine. Let me know if this works for you as well.



Message: 2
To: [email protected]
From: Rob Guglielmetti <[email protected]>
Date: Wed, 29 Oct 2003 11:11:16 -0500
Subject: [Radiance-general] Compiling Radiance on Panther (Mac OS X 10.3)
Reply-To: [email protected]


I recently picked up the new release of Apple's extraordinary operating
system (it's nice). I even performed what I like to call a "binary
enema", deleting my entire partition and installing the new OS fresh.
Naturally, one of the first proggies I wanted to get on here is
Radiance, but the install script that worked so well on 10.2 is having
problems on 10.3.

I downloaded the HEAD release, and tried:

sudo ./makeall install

Everything went well until:

  Where do you want the library files [/usr/local/lib/ray]?
  ls: lib: No such file or directory
  csh: d1: Subscript out of range.

The directory *is* there, and I own it, but even that shouldn't matter
because I'm trying to install it as root by using the sudo command.
Ideas? I could download the binaries, but that's so boring.

   Rob Guglielmetti
[email protected]