Problem with getting correct irradiance from sky dome

Hi Claus,

You need to specify the sky as a "glow" source -- sources that large are not accurately modeled in the direct calculation. See:

  http://radsite.lbl.gov/radiance/digests_html/v2n5.1.html#SKY

I suppose the renderer should issue a warning or something, but Radiance is kind of like a big pile of rope to hang yourself with.

Best,
-Greg

···

From: "Claus B. Madsen" <[email protected]>
Date: November 22, 2007 6:48:34 AM PST

Dear List,

I have problems getting trustworthy irradiances in a scene where I am using a 180 degree light source as a sky dome. For testing purposes I have created the following very simple setup: a groundplane with normal (0 0 1), and a 180 degree source with direction vector (0 0 1), the radiance of the source is RGB=(1 1 1) (unity radiance). I set the camera to look straight down on the groundplane and render using rpict -i to get irradiances. In theory such a source should result in an irradiance at the groundplane of exactly pi, but when I render I get approx.RGB=(4.77 4.77 4.77)

Any ideas for explanations? Any ideas for how to correct this?

Best,
Claus

The scene.rad file:
------------------------------------
# Materials
void plastic perfectlambert
0
5 1.0 1.0 1.0 0 0

#Geometry
!genbox perfectlambert groundplane 10000 10000 0.5 | xform -t -5000 -5000 -0.25

# Illumination environment: a 180 degree unity radiance skydome
void light skyradiance
0
3 1 1 1

skyradiance source TheSky
0
4 0 0 1 180.0
---------------------------------------------------------------------------------

The render parameters:

rpict -i -x 1024 -y 1024 -ab 4 -aw 1 -ps 1 -dt 0.0 -dr 3 -dp 8192 -ds 0.01 -dj 0.9 -dc 0.8 -u -vf scene.vp

And the scene.vp file:
---------------------------------
rview -vtv -vp 0.0 0.0 10.0 -vd 0.0 0.0 -1.0 -vu 0 1 0 -vh 45 -vv 45
----------------------------------------------------------------------

"Radiance is kind of like a big pile of rope to hang yourself with."
- Greg Ward

Quote of the year, thanks, Greg. Happy Thanksgiving all!

Hi Greg,

thanks for the super advice (and for Radiance :slight_smile:

Switching from light to glow solves the irradiance level problem. Now my problem (of course) is: I don't get "slightly dark patches" beneath objects standing on the ground plane as you would expect (due to partial occlusion of the incoming radiance from the sky dome). I.e., this use of glow (I dunno what to set maxrad to since the glow material is not applied to any geometry but just used for an infinitely distant skydome) doesn't allow the Sky dome to cast shadow.

... eh, and yes ... thanks for teaching me the Ropes of Radiance

Best,
Claus

Greg Ward wrote:

···

Hi Claus,

You need to specify the sky as a "glow" source -- sources that large are not accurately modeled in the direct calculation. See:

    http://radsite.lbl.gov/radiance/digests_html/v2n5.1.html#SKY

I suppose the renderer should issue a warning or something, but Radiance is kind of like a big pile of rope to hang yourself with.

Best,
-Greg

Hi Claus,

If you either increase your -ar setting or set -aa to 0, you will get better "contact shadows" as they are called.

Hope this helps.
-Greg

···

From: "Claus B. Madsen" <[email protected]>
Date: November 23, 2007 1:50:17 AM PST

Hi Greg,

thanks for the super advice (and for Radiance :slight_smile:

Switching from light to glow solves the irradiance level problem. Now my problem (of course) is: I don't get "slightly dark patches" beneath objects standing on the ground plane as you would expect (due to partial occlusion of the incoming radiance from the sky dome). I.e., this use of glow (I dunno what to set maxrad to since the glow material is not applied to any geometry but just used for an infinitely distant skydome) doesn't allow the Sky dome to cast shadow.

... eh, and yes ... thanks for teaching me the Ropes of Radiance

Best,
Claus