Noisy details in image with -ab 0

Dear All,

I am trying to render some images with only direct light i.e. -ab 0, but I am failing to get the details rendered properly and I get very noisy details. My geometry is fairly simple - a football field in a stadium with roof.

However in my renderings I am unable to get the white field markings to render properly.

These are my render parameters for rpict:

-ps 1 -dr 6 -pt 0.0 -as 512 -y 920 -pj 0.4 -st 0.15 -lw 2e-05 -dc 0.75 -ar 300 -ss 1.0 -dp 0 -ab 0 -x 1080 -dt 0.0 -ds 0.02 -aa 0.1 -lr 8 -ad 1024 -dj 0.0

My sincere apologies for the rookie question, but I have tried multiple permutations of different parameters but I can’t seem to get it right. I usually work with rtrace and I have a hard time getting parameters correct for a high quality render with rpict. Any hints would be appreciated.


Have you tried increasing the -pj pixel jitter setting to 0.9 or close to 1? After trying that, your best bet is probably to render an image at double or triple your desired resolution then use pfilt -x /2 -y /2 (or /3) to filter it down to the final size. If you used the rad command with high quality settings it would manage this process for you, but you’d have to learn that methodology if you’re not already familiar.


Hi Christopher,

Thanks for your swift reply.

Yes, I already tried altering -pj , but it didn’t help.
But yes enhancing the resolution solved it! That should have been obvious to me. I later scaled it backed with pfilt and all is good now.

Thanks once again and wish you a nice weekend ahead!