Issue about su2rad

Hi list,
I used the convenient plugin su2rad to build a room model from Sketchup to Radiance. However, when I open the file in Radiance and there is something wrong with its coordinates. As we know, the surface and its normal vector must obey the right hand rule in Radiance while the reality is just the opposite. Anyone who use the same plugin has the similar problem? Or is there any other way to build a correct model not using Radiance? Any advice is appreciated!

I don’t know anything about su2rad, but the xform -I option may be used to reverse surface normals if that’s all you need to fix the output.


Hi Greg,
Thanks for your reply! I tried “xform” after I got your advice and it worked well. However, I tried " xform -I " and some problem occurred this time. The file exists there and “xform” can’t find it. I am using Radiance( b714370f) and the environment variables are as follows. And I am not very clear about another basic question: How to install the compiled bin and lib folders of Radiance which is downloaded from GitHub? I hope I can get some suggestions, thanks!

I think you want the colon at the beginning of your RAYPATH rather than the end. More explicitly, it should be set to:


The ‘.’ says to search the current directory for files, and if it is missing, xform won’t find your file without explicitly using:

xform -I ./carpet.rad

Hi Greg,
I added . to $RAYPATH and xform was in effect. However, the scene file was not corrected.


It looks like xform reversed the order of the polygon’s vertices, thus reversing its surface normal as xform -I is designed to do. What did you expect to happen?

Hi Greg,
I am sorry that I forgot the command line of xform which I expect to use. It should be like this: xform -I door.rad > door1.rad. The new scene file door1.rad is what I want.