Implementation of rfluxmtx(radiance) with accelerad

Dear all,
I have installed Accelerad 0.6 beta for linux. AdditionalyI have installed Optix 3.9.1 in order to implement the rfluxmtx-acclerad in a more efficient way than rfluxmtx from radiance.

When I try to run the function rfluxmtx-accelerad (after facing all problems of dependency etc.) I have this error:

accelerad_rcontrib: internal - File not found (Details: Function “RTresult _rtProgramCreateFromPTXFile(RTcontext, const char*, const char*, RTprogram_api**)” caught exception:, [2031686])

I cannot understand what is the problem and what I have to fix. Is it an installation problem? I am not even sure if my installation is succesful, I cannot find any clear tutorial of how to install Optix succesfully.

Thank you in advance!
Kind regards.

Hi Lauren,

For Accelerad questions, it’s usually helpful to ask the Accelerad user group, although I’m happy to answer questions here, too.

On Linux, you need to update your PATH, RAYPATH, and LD_LIBRARY_PATH environment variables, as described in the documentation. You do not need to install OptiX unless you are building the source code.

To check that everything has installed successfully, try running the demos that are included with the installation.


Dear Nathaniel_Jones,
thank you for your quick response!

I updated my PATH, RAYPATH and LD_LIBRARY_PATH. I do not use the source code or Accelerad so I do not need to install Optix.
The demos are running succesfully.

I have Radiance installed by source code. Without the accelerad,Radiance is working fine. But when i call rfluxmtx-accelerad, I have the same error. I tried to run it even by copying the contents of the Accelerad bin folder into my Radiance bin folder, even by changing the paths to refer to the corresponding Accelerad program in my application.

Any ideas of how I could solve this?
I am sorry for answering again in a wrong group of topics, I will ask to the Accelerad user group too.

Thank you in advance,
Kind regards

This issue was resolved on the Accelerad user group. It turned out that rcontrib did not have permission to read the Accelerad ptx files when called by rfluxmtx. The solution was to give read access to all users for the ptx files.